summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-26 18:05:30 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-26 18:05:30 +0000
commitb2932844ef7a16a94294886d4dd0ef98b5852b6a (patch)
tree98ce2d86feabf1b648dee59e03352f960308d3d8 /dev-ruby/activerecord
parentVersion bump for Rails 3.0.7. (diff)
downloadgentoo-2-b2932844ef7a16a94294886d4dd0ef98b5852b6a.tar.gz
gentoo-2-b2932844ef7a16a94294886d4dd0ef98b5852b6a.tar.bz2
gentoo-2-b2932844ef7a16a94294886d4dd0ef98b5852b6a.zip
Version bump for Rails 3.0.7.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.7.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index aec6304099cc..9af70f1ee746 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.151 2011/02/21 20:11:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.152 2011/04/26 18:05:30 graaff Exp $
+
+*activerecord-3.0.7 (26 Apr 2011)
+
+ 26 Apr 2011; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-3.0.7.ebuild:
+ Version bump for Rails 3.0.7.
*activerecord-2.3.11 (21 Feb 2011)
diff --git a/dev-ruby/activerecord/activerecord-3.0.7.ebuild b/dev-ruby/activerecord/activerecord-3.0.7.ebuild
new file mode 100644
index 000000000000..15214562b82f
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.7.ebuild,v 1.1 2011/04/26 18:05:30 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+S="${WORKDIR}/rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.2
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( dev-ruby/mysql2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/actionpack-${PV}
+ dev-ruby/sqlite3-ruby
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}