summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 11:44:25 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 11:44:25 +0000
commit62b141e6b2cdd2dcda49aeca839923f7255db48a (patch)
tree657b46475354cf6000e20ffc2bfbed03b2ff34b2 /dev-ruby/activeresource
parentVersion bump for Rails 3.1.4, security bug 406547. (diff)
downloadgentoo-2-62b141e6b2cdd2dcda49aeca839923f7255db48a.tar.gz
gentoo-2-62b141e6b2cdd2dcda49aeca839923f7255db48a.tar.bz2
gentoo-2-62b141e6b2cdd2dcda49aeca839923f7255db48a.zip
Version bump for Rails 3.1.4, security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.1.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 34ea21113c0b..56b850fb8b94 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.105 2012/04/04 09:26:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.106 2012/04/04 11:44:25 graaff Exp $
+
+*activeresource-3.1.4 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activeresource-3.1.4.ebuild:
+ Version bump for Rails 3.1.4, security bug 406547.
*activeresource-3.0.12 (04 Apr 2012)
diff --git a/dev-ruby/activeresource/activeresource-3.1.4.ebuild b/dev-ruby/activeresource/activeresource-3.1.4.ebuild
new file mode 100644
index 000000000000..debaa4175215
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.1.4.ebuild,v 1.1 2012/04/04 11:44:25 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}