summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-31 07:42:49 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-31 07:42:49 +0000
commit215a30a48031166b57b5225c50a9caccd0c95127 (patch)
tree7382b5c11f2436cc96d72a6d111824ceea6a2dd8 /dev-ruby/activesupport
parentsync the USE settings from base/make.defaults #463530 (diff)
downloadgentoo-2-215a30a48031166b57b5225c50a9caccd0c95127.tar.gz
gentoo-2-215a30a48031166b57b5225c50a9caccd0c95127.tar.bz2
gentoo-2-215a30a48031166b57b5225c50a9caccd0c95127.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.13.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 8fa2d76f0f9f..233fd929ac15 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.222 2013/03/30 13:15:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.223 2013/03/31 07:42:49 graaff Exp $
+
+*activesupport-3.2.13 (31 Mar 2013)
+
+ 31 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.13.ebuild:
+ Version bump for security bug 462452.
*activesupport-3.1.12 (30 Mar 2013)
diff --git a/dev-ruby/activesupport/activesupport-3.2.13.ebuild b/dev-ruby/activesupport/activesupport-3.2.13.ebuild
new file mode 100644
index 000000000000..a07fd7997d56
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.13.ebuild,v 1.1 2013/03/31 07:42:49 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/i18n-0.6.1:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/memcache-client-1.5.8
+ dev-ruby/nokogiri
+ >=dev-ruby/builder-3.0.3:3
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+# libxml is not strictly needed, there are tests using this code. jruby
+# uses a different xml implementation.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Ignore failing tests on jruby in the interest of a security update
+ sed -i -e '/test_not_allowed_to_expand_parameter_entities_to_files/,/^ end/ s:^:#:' \
+ -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
+ test/xml_mini/jdom_engine_test.rb || die
+
+ # Make i18n dependency more lenient since we don't have broken versions
+ # 0.6.2/0.6.3.
+ sed -i -e 's/= 0.6.1/~> 0.6.1/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}