summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 09:31:34 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 09:31:34 +0000
commit3e705fd7024a1fd883ba711b1ed1118219a03567 (patch)
treeafdacfe90d7aded17ac675fe844e040bf3eb0920 /dev-ruby/activesupport
parentMissing USE="udev" check for sys-apps/hwids in pkg_postinst() hwdb database u... (diff)
downloadgentoo-2-3e705fd7024a1fd883ba711b1ed1118219a03567.tar.gz
gentoo-2-3e705fd7024a1fd883ba711b1ed1118219a03567.tar.bz2
gentoo-2-3e705fd7024a1fd883ba711b1ed1118219a03567.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.18.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 51376b4412a3..54233fe93832 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.220 2013/03/27 13:42:49 moult Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.221 2013/03/30 09:31:34 graaff Exp $
+
+*activesupport-2.3.18 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-2.3.18.ebuild:
+ Version bump for security bug 462452.
27 Mar 2013; Dion Moult <moult@gentoo.org> -activesupport-3.0.20.ebuild:
Remove dev-ruby/activesupport:3.0 due to lack of upstream support.
diff --git a/dev-ruby/activesupport/activesupport-2.3.18.ebuild b/dev-ruby/activesupport/activesupport-2.3.18.ebuild
new file mode 100644
index 000000000000..a03860c05f50
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.18.ebuild,v 1.1 2013/03/30 09:31:34 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as well
+ # as fixing the dependencies for i18n to use the correct slot. It
+ # also edits the metadata file so that the dependencies are added to
+ # the specification, which is required for bundler to pick them up
+ # (which in turn is required by radiant 1.0.0rc3 to
+ # work). Furthermore remove the references to the vendorized copies
+ # from the specification, to be safe.
+ mv ../metadata . || die
+ epatch "${FILESDIR}"/${PN}-2.3.16-unvendorize.patch
+ mv metadata .. || die
+ sed -i -e '/\/vendor\//d' ../metadata
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}