summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-12 19:03:25 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-12 19:03:25 +0000
commit4f2e6bd770d01a838d5499f7e00aec49bbdbf95c (patch)
tree2a48b1c26e5ad0296231198c2d6b300461a1889f /dev-ruby/activesupport
parentCleanup. (diff)
downloadgentoo-2-4f2e6bd770d01a838d5499f7e00aec49bbdbf95c.tar.gz
gentoo-2-4f2e6bd770d01a838d5499f7e00aec49bbdbf95c.tar.bz2
gentoo-2-4f2e6bd770d01a838d5499f7e00aec49bbdbf95c.zip
Cleanup.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.17.ebuild75
-rw-r--r--dev-ruby/activesupport/activesupport-4.0.3.ebuild58
-rw-r--r--dev-ruby/activesupport/activesupport-4.0.4.ebuild58
-rw-r--r--dev-ruby/activesupport/activesupport-4.1.0.ebuild53
5 files changed, 6 insertions, 245 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index ff8fa647ffd5..e5bc411c5728 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.256 2014/05/06 19:59:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.257 2014/05/12 19:03:25 graaff Exp $
+
+ 12 May 2014; Hans de Graaff <graaff@gentoo.org> -activesupport-3.2.17.ebuild,
+ -activesupport-4.0.3.ebuild, -activesupport-4.0.4.ebuild,
+ -activesupport-4.1.0.ebuild:
+ Cleanup.
*activesupport-4.1.1 (06 May 2014)
diff --git a/dev-ruby/activesupport/activesupport-3.2.17.ebuild b/dev-ruby/activesupport/activesupport-3.2.17.ebuild
deleted file mode 100644
index 7a00e4619d8a..000000000000
--- a/dev-ruby/activesupport/activesupport-3.2.17.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.17.ebuild,v 1.4 2014/04/21 10:30:49 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.0
- >=dev-ruby/i18n-0.6.4:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- >=dev-ruby/memcache-client-1.5.8
- dev-ruby/nokogiri
- >=dev-ruby/builder-3.0.3:3
- >=dev-ruby/tzinfo-0.3.29
- )"
-
-# libxml is not strictly needed, there are tests using this code. jruby
-# uses a different xml implementation.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby18)
- # Skip failing ruby18 tests related to JSON serialization
- rm test/message_encryptor_test.rb test/message_verifier_test.rb || die
- ;;
- *jruby)
- # Ignore failing tests on jruby in the interest of a security update
- sed -i -e '/test_not_allowed_to_expand_parameter_entities_to_files/,/^ end/ s:^:#:' \
- -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
- test/xml_mini/jdom_engine_test.rb || die
- sed -i \
- -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
- test/xml_mini/nokogiri_engine_test.rb || die
- ;;
- esac
-}
diff --git a/dev-ruby/activesupport/activesupport-4.0.3.ebuild b/dev-ruby/activesupport/activesupport-4.0.3.ebuild
deleted file mode 100644
index 65cfd400d36a..000000000000
--- a/dev-ruby/activesupport/activesupport-4.0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.0.3.ebuild,v 1.3 2014/05/04 13:49:42 jer Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.3:0
- >=dev-ruby/i18n-0.6.4:0.6
- >=dev-ruby/tzinfo-0.3.37:0
- >=dev-ruby/minitest-4.2:0
- >=dev-ruby/thread_safe-0.1:0
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/libxml-2.0.0
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Make sure a compatible version of minitest is used everywhere.
- sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
- sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
-}
diff --git a/dev-ruby/activesupport/activesupport-4.0.4.ebuild b/dev-ruby/activesupport/activesupport-4.0.4.ebuild
deleted file mode 100644
index 9c8f279c7109..000000000000
--- a/dev-ruby/activesupport/activesupport-4.0.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.0.4.ebuild,v 1.3 2014/05/04 13:49:42 jer Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.3:0
- >=dev-ruby/i18n-0.6.9:0.6
- >=dev-ruby/tzinfo-0.3.37:0
- >=dev-ruby/minitest-4.2:0
- >=dev-ruby/thread_safe-0.1:0
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/libxml-2.0.0
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Make sure a compatible version of minitest is used everywhere.
- sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
- sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
-}
diff --git a/dev-ruby/activesupport/activesupport-4.1.0.ebuild b/dev-ruby/activesupport/activesupport-4.1.0.ebuild
deleted file mode 100644
index 82a8023ac293..000000000000
--- a/dev-ruby/activesupport/activesupport-4.1.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.1.0.ebuild,v 1.2 2014/05/04 13:49:42 jer Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/i18n-0.6.9:0.6
- >=dev-ruby/json-1.7.7:0
- >=dev-ruby/tzinfo-1.1:1
- >=dev-ruby/minitest-5.1:5
- >=dev-ruby/thread_safe-0.1:0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/libxml-2.0.0
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}