summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-26 08:46:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-26 08:46:41 +0000
commitfef6118682d893ca2721040bd55628d5a036a76f (patch)
tree9ea397f7b79132bc82b653518baafea81239525b /dev-ruby/activesupport
parentFix drop-jreality-patch and libexecdir, thanks Benjamin Lorenz (diff)
downloadgentoo-2-fef6118682d893ca2721040bd55628d5a036a76f.tar.gz
gentoo-2-fef6118682d893ca2721040bd55628d5a036a76f.tar.bz2
gentoo-2-fef6118682d893ca2721040bd55628d5a036a76f.zip
Make sure only the latest slot installs binaries in /usr/bin.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.11-r1.ebuild45
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.3.ebuild5
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index efdea68d509d..fc211b104cef 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.159 2011/12/26 08:25:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.160 2011/12/26 08:46:41 graaff Exp $
+
+*activesupport-3.0.11-r1 (26 Dec 2011)
+
+ 26 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-3.0.11-r1.ebuild, activesupport-3.1.3.ebuild:
+ Make sure only the latest slot installs binaries in /usr/bin.
*activesupport-3.1.3 (26 Dec 2011)
diff --git a/dev-ruby/activesupport/activesupport-3.0.11-r1.ebuild b/dev-ruby/activesupport/activesupport-3.0.11-r1.ebuild
new file mode 100644
index 000000000000..69be16cb6419
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.11-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.11-r1.ebuild,v 1.1 2011/12/26 08:46:41 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activesupport/activesupport-3.1.3.ebuild b/dev-ruby/activesupport/activesupport-3.1.3.ebuild
index 24668bc00007..017a93c3fbaa 100644
--- a/dev-ruby/activesupport/activesupport-3.1.3.ebuild
+++ b/dev-ruby/activesupport/activesupport-3.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.3.ebuild,v 1.1 2011/12/26 08:25:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.3.ebuild,v 1.2 2011/12/26 08:46:41 graaff Exp $
EAPI=4
@@ -28,7 +28,8 @@ RUBY_S="rails-rails-*/${PN}"
ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
>=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6"
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
# libxml-ruby, nokogiri, and builder are not strictly needed, but there
# are tests using this code.