summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:17:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:17:28 +0000
commit8bc4ab7562d332eedbd117c2db3326254a9d39cf (patch)
tree784773b4120a55a350c74f70ebf7ea2f1509b356 /dev-ruby/attic
parentVersion bump per bug #294934. (diff)
downloadgentoo-2-8bc4ab7562d332eedbd117c2db3326254a9d39cf.tar.gz
gentoo-2-8bc4ab7562d332eedbd117c2db3326254a9d39cf.tar.bz2
gentoo-2-8bc4ab7562d332eedbd117c2db3326254a9d39cf.zip
Initial import of attic needed ultimately for rudy.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/attic')
-rw-r--r--dev-ruby/attic/ChangeLog10
-rw-r--r--dev-ruby/attic/attic-0.5.0.ebuild38
-rw-r--r--dev-ruby/attic/files/attic-0.5.0-fixes.patch44
-rw-r--r--dev-ruby/attic/metadata.xml5
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-ruby/attic/ChangeLog b/dev-ruby/attic/ChangeLog
new file mode 100644
index 000000000000..da6d438563cd
--- /dev/null
+++ b/dev-ruby/attic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/attic
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/attic/ChangeLog,v 1.1 2010/02/14 00:17:26 flameeyes Exp $
+
+*attic-0.5.0 (14 Feb 2010)
+
+ 14 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org> +attic-0.5.0.ebuild,
+ +files/attic-0.5.0-fixes.patch, +metadata.xml:
+ Initial import of attic needed ultimately for rudy.
+
diff --git a/dev-ruby/attic/attic-0.5.0.ebuild b/dev-ruby/attic/attic-0.5.0.ebuild
new file mode 100644
index 000000000000..905a0eb52317
--- /dev/null
+++ b/dev-ruby/attic/attic-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/attic/attic-0.5.0.ebuild,v 1.1 2010/02/14 00:17:26 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A place for Ruby objects to hide instance variables"
+HOMEPAGE="http://solutious.com/"
+
+SRC_URI="http://github.com/delano/${PN}/tarball/${P} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-cda0a77"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend test dev-ruby/tryouts
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-fixes.patch
+}
+
+each_ruby_test() {
+ ${RUBY} -S sergeant || die "tests failed"
+}
diff --git a/dev-ruby/attic/files/attic-0.5.0-fixes.patch b/dev-ruby/attic/files/attic-0.5.0-fixes.patch
new file mode 100644
index 000000000000..cde7b5a07b39
--- /dev/null
+++ b/dev-ruby/attic/files/attic-0.5.0-fixes.patch
@@ -0,0 +1,44 @@
+diff --git a/Rakefile b/Rakefile
+index eebef10..3a8edfc 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -65,6 +64,11 @@ end
+
+
+ # RUBY DOCS TASK ==================================
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
+
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
+diff --git a/try/30_nometaclass_tryouts.rb b/try/30_nometaclass_tryouts.rb
+index 0a07843..94f3ea8 100644
+--- a/try/30_nometaclass_tryouts.rb
++++ b/try/30_nometaclass_tryouts.rb
+@@ -30,13 +30,13 @@ tryouts "Basics" do
+ :any.metaclass?
+ end
+
+- dream [:@___attic_name]
++ dream ["@___attic_name"]
+ drill "A Symbol's attic vars appear in all_instance_variables" do
+ Symbol.extend Attic
+ Symbol.attic :name
+ a, b = :symbol1, :symbol2
+ a.name = :roger
+- a.all_instance_variables
++ a.all_instance_variables.collect { |x| x.to_s }
+ end
+
+ dream []
diff --git a/dev-ruby/attic/metadata.xml b/dev-ruby/attic/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/attic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>