summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-16 08:29:47 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-16 08:29:47 +0000
commit421d4eece1bc81277af965397c3cfc5cf3657cef (patch)
tree86d8c76b65dfb7e666997f1282b438398aebd965 /dev-ruby/bundler
parentPatch the "Use of uninitialized value" warning (diff)
downloadgentoo-2-421d4eece1bc81277af965397c3cfc5cf3657cef.tar.gz
gentoo-2-421d4eece1bc81277af965397c3cfc5cf3657cef.tar.bz2
gentoo-2-421d4eece1bc81277af965397c3cfc5cf3657cef.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/ChangeLog8
-rw-r--r--dev-ruby/bundler/bundler-1.0.3.ebuild45
-rw-r--r--dev-ruby/bundler/files/bundler-1.0.3-gentoo.patch20
3 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 3449e8952b85..980406f7c6fa 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.5 2010/06/30 12:05:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.6 2010/10/16 08:29:47 graaff Exp $
+
+*bundler-1.0.3 (16 Oct 2010)
+
+ 16 Oct 2010; Hans de Graaff <graaff@gentoo.org> +bundler-1.0.3.ebuild,
+ +files/bundler-1.0.3-gentoo.patch:
+ Version bump.
30 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
bundler-0.9.26.ebuild:
diff --git a/dev-ruby/bundler/bundler-1.0.3.ebuild b/dev-ruby/bundler/bundler-1.0.3.ebuild
new file mode 100644
index 000000000000..e768747851fc
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.3.ebuild,v 1.1 2010/10/16 08:29:47 graaff Exp $
+
+EAPI=2
+
+# ruby19 → uncountable number of test failures
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/rubygems
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+all_ruby_prepare() {
+ # Reported upstream: http://github.com/carlhuda/bundler/issues#issue/771
+ sed -i -e 's:Your bundle was installed to `vendor`:It was installed into ./vendor:' -e 's:Your bundle was installed to `vendor/bundle`:It was installed into ./vendor/bundle:' spec/install/gems/simple_case_spec.rb || die
+
+ # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '159s/should/should_not/' spec/runtime/environment_rb_spec.rb || die
+}
diff --git a/dev-ruby/bundler/files/bundler-1.0.3-gentoo.patch b/dev-ruby/bundler/files/bundler-1.0.3-gentoo.patch
new file mode 100644
index 000000000000..5667e87628ff
--- /dev/null
+++ b/dev-ruby/bundler/files/bundler-1.0.3-gentoo.patch
@@ -0,0 +1,20 @@
+diff --git a/bin/bundle b/bin/bundle
+index d2e5081..17db3f0 100755
+--- a/bin/bundle
++++ b/bin/bundle
+@@ -1,9 +1,14 @@
+ #!/usr/bin/env ruby
+
+ # Check if an older version of bundler is installed
++mybasedir = __FILE__.gsub(/\/bin\/bundle/, '')
++
+ require 'bundler'
+ $:.each do |path|
+- if path =~ %r'/bundler-0.(\d+)' && $1.to_i < 9
++ # ignore the directory we're running from, in the tests
++ path = path.gsub(%r"^#{mybasedir}", '')
++
++ if path =~ %r'/bundler-0\.(\d+)' && $1.to_i < 9
+ abort "Please remove older versions of bundler. This can be done by running `gem cleanup bundler`."
+ end
+ end