summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-16 12:35:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-16 12:35:55 +0000
commit66a445575d4f1aed82155a49950b11bc29a78157 (patch)
treed462b220a09fae3e1e12da1464dc713f90b5530c /dev-ruby/caesars/caesars-0.7.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-66a445575d4f1aed82155a49950b11bc29a78157.tar.gz
gentoo-2-66a445575d4f1aed82155a49950b11bc29a78157.tar.bz2
gentoo-2-66a445575d4f1aed82155a49950b11bc29a78157.zip
Version bump, drop patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/caesars/caesars-0.7.4.ebuild')
-rw-r--r--dev-ruby/caesars/caesars-0.7.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/caesars/caesars-0.7.4.ebuild b/dev-ruby/caesars/caesars-0.7.4.ebuild
new file mode 100644
index 000000000000..252f4f24f1b0
--- /dev/null
+++ b/dev-ruby/caesars/caesars-0.7.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/caesars/caesars-0.7.4.ebuild,v 1.1 2010/03/16 12:35:53 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rapid DSL prototyping in Ruby."
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#ruby_add_bdepend test dev-ruby/tryouts
+
+# Tests currenty fail for all implementations
+# http://github.com/delano/gibbler/issues/issue/1
+RESTRICT=test
+
+# Tests are not in the released gem, but since we don't run them we
+# don't need the whole sources as it is.
+
+#SRC_URI="http://github.com/delano/${PN}/tarball/${P} -> ${PN}-git-${PV}.tgz"
+#S="${WORKDIR}/delano-${PN}-3629f49"
+
+each_ruby_test() {
+ ${RUBY} -S sergeant || die "tests failed"
+}