summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-13 03:25:08 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-13 03:25:08 +0000
commit1c5409dfa34178e06b0b62fda8125d7c94cd2c7d (patch)
tree40776181f96035e748c57e42db71ad335408ed8e /dev-ruby/classifier
parentVersion bump. (diff)
downloadgentoo-2-1c5409dfa34178e06b0b62fda8125d7c94cd2c7d.tar.gz
gentoo-2-1c5409dfa34178e06b0b62fda8125d7c94cd2c7d.tar.bz2
gentoo-2-1c5409dfa34178e06b0b62fda8125d7c94cd2c7d.zip
Version bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/classifier')
-rw-r--r--dev-ruby/classifier/ChangeLog9
-rw-r--r--dev-ruby/classifier/classifier-1.3.4.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ruby/classifier/ChangeLog b/dev-ruby/classifier/ChangeLog
index 61c7508c9d20..55af9ac3594a 100644
--- a/dev-ruby/classifier/ChangeLog
+++ b/dev-ruby/classifier/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/classifier
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier/ChangeLog,v 1.1 2013/11/30 22:56:24 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier/ChangeLog,v 1.2 2014/01/13 03:25:08 mrueg Exp $
+
+*classifier-1.3.4 (13 Jan 2014)
+
+ 13 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +classifier-1.3.4.ebuild:
+ Version bump.
*classifier-1.3.3 (30 Nov 2013)
diff --git a/dev-ruby/classifier/classifier-1.3.4.ebuild b/dev-ruby/classifier/classifier-1.3.4.ebuild
new file mode 100644
index 000000000000..f4f3546215be
--- /dev/null
+++ b/dev-ruby/classifier/classifier-1.3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier/classifier-1.3.4.ebuild,v 1.1 2014/01/13 03:25:08 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="http://rubyforge.org/projects/classifier https://github.com/cardmagic/classifier"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0"
+ruby_add_rdepend "gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "s/PKG_VERSION/\"${PV}\"/" \
+ -e "s#PKG_FILES#FileList[ \"lib/**/*\", \"bin/*\", \"test/**/*\", \"[A-Z]*\", \"Rakefile\", \"Gemfile\", \"html/**/*\"]#" Rakefile
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/' -i lib/${PN}/lsi.rb || die
+ rm test/lsi/lsi_test.rb || die
+ fi
+ # Remove failing test for now
+ rm test/extensions/word_hash_test.rb || die
+}