summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-14 06:11:20 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-14 06:11:20 +0000
commit1232f1acb92d2e4e03c0cbb27433c597fda7827e (patch)
treed34dbe0180d3ddb61186aac5c83fc6b156cf871a /dev-ruby/coolio
parentSecurity bump (diff)
downloadgentoo-2-1232f1acb92d2e4e03c0cbb27433c597fda7827e.tar.gz
gentoo-2-1232f1acb92d2e4e03c0cbb27433c597fda7827e.tar.bz2
gentoo-2-1232f1acb92d2e4e03c0cbb27433c597fda7827e.zip
Version bump. Unbundle iobuffer. Compile directly instead of via unspecified rake-compiler. Run all non-network specs.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/ChangeLog8
-rw-r--r--dev-ruby/coolio/coolio-1.2.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/coolio/ChangeLog b/dev-ruby/coolio/ChangeLog
index bab18f99dd7d..64ac62f04da4 100644
--- a/dev-ruby/coolio/ChangeLog
+++ b/dev-ruby/coolio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/coolio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/ChangeLog,v 1.5 2013/02/03 12:20:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/ChangeLog,v 1.6 2013/07/14 06:11:20 graaff Exp $
+
+*coolio-1.2.0 (14 Jul 2013)
+
+ 14 Jul 2013; Hans de Graaff <graaff@gentoo.org> +coolio-1.2.0.ebuild:
+ Version bump. Unbundle iobuffer. Compile directly instead of via unspecified
+ rake-compiler. Run all non-network specs.
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #22900
diff --git a/dev-ruby/coolio/coolio-1.2.0.ebuild b/dev-ruby/coolio/coolio-1.2.0.ebuild
new file mode 100644
index 000000000000..ec6a546b7110
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/coolio-1.2.0.ebuild,v 1.1 2013/07/14 06:11:20 graaff Exp $
+
+EAPI=5
+
+# iobuffer: -jruby -rbx
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="http://coolio.github.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libev"
+RDEPEND="${DEPEND}"
+
+RUBY_PATCHES=( "${PN}-1.1.0-libev.patch" "${PN}-1.1.0-rubyio.patch" )
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-1"
+
+all_ruby_prepare() {
+ rm -r Gemfile* ext/libev ext/cool.io/libev.c lib/.gitignore || die
+
+ sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove specs that require network connectivity
+ rm spec/dns_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cool.io extconf.rb || die
+ ${RUBY} -Cext/http11_client extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cool.io
+ cp ext/cool.io/cool.io_ext$(get_modname) lib/ || die
+
+ emake V=1 -Cext/http11_client
+ cp ext/http11_client/http11_client$(get_modname) lib/ || die
+}