summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-07 09:06:57 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-07 09:06:57 +0000
commit12d63088e5a7c917ff252aedd725a0160c84f585 (patch)
tree3df5ffb8ca283345a14b208786c288a4f479f9b9 /dev-ruby/daemon_controller
parentVersion bump. (diff)
downloadgentoo-2-12d63088e5a7c917ff252aedd725a0160c84f585.tar.gz
gentoo-2-12d63088e5a7c917ff252aedd725a0160c84f585.tar.bz2
gentoo-2-12d63088e5a7c917ff252aedd725a0160c84f585.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/ChangeLog8
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.0.0.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index 198ff1719ca6..f3b75d0aeb5b 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemon_controller
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.6 2012/04/01 06:30:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.7 2012/04/07 09:06:57 graaff Exp $
+
+*daemon_controller-1.0.0 (07 Apr 2012)
+
+ 07 Apr 2012; Hans de Graaff <graaff@gentoo.org>
+ +daemon_controller-1.0.0.ebuild:
+ Version bump.
*daemon_controller-0.2.6-r1 (01 Apr 2012)
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.0.0.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.0.0.ebuild
new file mode 100644
index 000000000000..040dd45d126a
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-1.0.0.ebuild,v 1.1 2012/04/07 09:06:57 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 ) "
+
+each_ruby_test() {
+ ${RUBY} -S spec spec || die "Tests failed."
+}