summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-30 20:14:09 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-30 20:14:09 +0000
commit8c2f4a9d7cc09e96558095dc03871fca19121f1c (patch)
tree2d1f85d7d7f1b43b689d3579357a70a05e57aac8 /dev-ruby/ffi
parentAdd patch to fix one issue with Ruby 1.9 (tempfile behaviour); also apply to ... (diff)
downloadgentoo-2-8c2f4a9d7cc09e96558095dc03871fca19121f1c.tar.gz
gentoo-2-8c2f4a9d7cc09e96558095dc03871fca19121f1c.tar.bz2
gentoo-2-8c2f4a9d7cc09e96558095dc03871fca19121f1c.zip
Deal with github changing their tarball generation.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ffi')
-rw-r--r--dev-ruby/ffi/ChangeLog6
-rw-r--r--dev-ruby/ffi/ffi-0.6.2.ebuild49
-rw-r--r--dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch29
3 files changed, 5 insertions, 79 deletions
diff --git a/dev-ruby/ffi/ChangeLog b/dev-ruby/ffi/ChangeLog
index b36163d3435f..4b365197cdbe 100644
--- a/dev-ruby/ffi/ChangeLog
+++ b/dev-ruby/ffi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ffi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.5 2010/04/30 20:13:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.6 2010/04/30 20:14:09 graaff Exp $
+
+ 30 Apr 2010; Hans de Graaff <graaff@gentoo.org> -ffi-0.6.2.ebuild,
+ -files/ffi-0.6.2-genRakefile.patch:
+ Deal with github changing their tarball generation.
*ffi-0.6.3 (30 Apr 2010)
diff --git a/dev-ruby/ffi/ffi-0.6.2.ebuild b/dev-ruby/ffi/ffi-0.6.2.ebuild
deleted file mode 100644
index d9ebe3d30975..000000000000
--- a/dev-ruby/ffi/ffi-0.6.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-0.6.2.ebuild,v 1.1 2010/02/16 11:01:26 flameeyes Exp $
-
-EAPI=2
-
-# jruby → unneeded, this is part of the standard JRuby distribution,
-# and would just install a dummy
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
-HOMEPAGE="http://wiki.github.com/ffi/ffi"
-
-SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/${PN}-${PN}-7abe057"
-
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-libs/libffi"
-DEPEND="${RDEPEND}"
-
-ruby_add_bdepend dev-ruby/rake-compiler
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-genRakefile.patch
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "compile failed"
- ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/* || die
-}
diff --git a/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch b/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch
deleted file mode 100644
index f18eea51aba0..000000000000
--- a/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 1d2ac1eae074af39b447a5bd7fe8a668e60517fd Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
-Date: Tue, 16 Feb 2010 11:48:22 +0100
-Subject: [PATCH 1/2] Use the __FILE__ value to find the proper path for the ffi code.
-
-This replace the old code that relied on the RUBYLIBDIR environment
-variable and the position of the current work directory.
----
- gen/Rakefile | 6 ++++--
- 1 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/gen/Rakefile b/gen/Rakefile
-index f97f845..2f5bdb9 100644
---- a/gen/Rakefile
-+++ b/gen/Rakefile
-@@ -1,6 +1,8 @@
- require 'fileutils'
--require "#{File.join(ENV['RUBYLIBDIR'], 'ffi', 'tools', 'types_generator.rb')}"
--types_conf = File.join(ENV['RUBYLIBDIR'], 'ffi', 'types.conf')
-+require 'pathname'
-+require Pathname.new(__FILE__).dirname + "../lib/ffi/tools/types_generator.rb"
-+types_conf = (Pathname.new(__FILE__).dirname + "../lib/ffi/types.conf").to_s
-+
- file types_conf do |task|
- options = {}
- FileUtils.mkdir_p(File.dirname(task.name), { :mode => 0755 })
---
-1.7.0
-