summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-30 18:17:48 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-30 18:17:48 +0000
commit0787fdfeff1b66f753f38d722f235b75a5d26a7e (patch)
treef205a4879482817b8dd4acb8782f5a2d2e606109 /dev-ruby/hpricot
parentUse elog instead of ewarn (diff)
downloadgentoo-2-0787fdfeff1b66f753f38d722f235b75a5d26a7e.tar.gz
gentoo-2-0787fdfeff1b66f753f38d722f235b75a5d26a7e.tar.bz2
gentoo-2-0787fdfeff1b66f753f38d722f235b75a5d26a7e.zip
Revision bump to create stable candidate.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hpricot')
-rw-r--r--dev-ruby/hpricot/ChangeLog8
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.4-r1.ebuild41
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.4.ebuild4
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-ruby/hpricot/ChangeLog b/dev-ruby/hpricot/ChangeLog
index 10c897035911..96817789c1a5 100644
--- a/dev-ruby/hpricot/ChangeLog
+++ b/dev-ruby/hpricot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hpricot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.29 2011/04/20 11:00:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.30 2011/05/30 18:17:48 graaff Exp $
+
+*hpricot-0.8.4-r1 (30 May 2011)
+
+ 30 May 2011; Hans de Graaff <graaff@gentoo.org> hpricot-0.8.4.ebuild,
+ +hpricot-0.8.4-r1.ebuild:
+ Revision bump to create stable candidate.
20 Apr 2011; Hans de Graaff <graaff@gentoo.org> -hpricot-0.8.3.ebuild:
Remove old version.
diff --git a/dev-ruby/hpricot/hpricot-0.8.4-r1.ebuild b/dev-ruby/hpricot/hpricot-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..1392ad3efea8
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.4-r1.ebuild,v 1.1 2011/05/30 18:17:48 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby."
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND="${DEPEND}
+ dev-util/ragel
+ ruby_targets_jruby? ( >=virtual/jdk-1.5 )"
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rake-compiler
+ test? ( virtual/ruby-test-unit )"
+
+each_ruby_compile() {
+ case $(basename ${RUBY}) in
+ jruby)
+ ${RUBY} -S rake compile_java || die "rake compile failed"
+ ;;
+ *)
+ ${RUBY} -S rake compile || die "rake compile failed"
+ ;;
+ esac
+}
diff --git a/dev-ruby/hpricot/hpricot-0.8.4.ebuild b/dev-ruby/hpricot/hpricot-0.8.4.ebuild
index a64cbe0c5faf..7113f26df65d 100644
--- a/dev-ruby/hpricot/hpricot-0.8.4.ebuild
+++ b/dev-ruby/hpricot/hpricot-0.8.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.4.ebuild,v 1.1 2011/03/01 07:16:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.4.ebuild,v 1.2 2011/05/30 18:17:48 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"