summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-11-07 06:09:19 +0000
committerHans de Graaff <graaff@gentoo.org>2010-11-07 06:09:19 +0000
commitc693865fc767ca62f79fb10c601f42231b01355f (patch)
treecd11761f0ab63e7bd5e01b1ea04ba0350e580d6c /dev-ruby/hpricot
parentVersion bump. (diff)
downloadgentoo-2-c693865fc767ca62f79fb10c601f42231b01355f.tar.gz
gentoo-2-c693865fc767ca62f79fb10c601f42231b01355f.tar.bz2
gentoo-2-c693865fc767ca62f79fb10c601f42231b01355f.zip
Version bump. Drop patch applied by upstream.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hpricot')
-rw-r--r--dev-ruby/hpricot/ChangeLog7
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/hpricot/ChangeLog b/dev-ruby/hpricot/ChangeLog
index 4ed15fac3a1f..64e9d596ed47 100644
--- a/dev-ruby/hpricot/ChangeLog
+++ b/dev-ruby/hpricot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hpricot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.24 2010/09/26 18:14:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.25 2010/11/07 06:09:19 graaff Exp $
+
+*hpricot-0.8.3 (07 Nov 2010)
+
+ 07 Nov 2010; Hans de Graaff <graaff@gentoo.org> +hpricot-0.8.3.ebuild:
+ Version bump. Drop patch applied by upstream.
26 Sep 2010; Hans de Graaff <graaff@gentoo.org> hpricot-0.8.2-r1.ebuild:
Drop ruby19 to make this a stable candidate.
diff --git a/dev-ruby/hpricot/hpricot-0.8.3.ebuild b/dev-ruby/hpricot/hpricot-0.8.3.ebuild
new file mode 100644
index 000000000000..81e5536dca6d
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.3.ebuild,v 1.1 2010/11/07 06:09:19 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby."
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND="${DEPEND}
+ dev-util/ragel
+ ruby_targets_jruby? ( >=virtual/jdk-1.5 )"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+each_ruby_compile() {
+ case $(basename ${RUBY}) in
+ jruby)
+ ${RUBY} -S rake compile_java || die "rake compile failed"
+ ;;
+ *)
+ ${RUBY} -S rake compile || die "rake compile failed"
+ ;;
+ esac
+}