summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-03-19 06:35:17 +0000
committerHans de Graaff <graaff@gentoo.org>2012-03-19 06:35:17 +0000
commit36fffa4854cd2671c8fcc39d225c403bbb43cb44 (patch)
tree3a003e075437f2020a390a3b14cdd1d6a078a2da /dev-ruby/libxml/libxml-2.3.0.ebuild
parentRemove old. (diff)
downloadgentoo-2-36fffa4854cd2671c8fcc39d225c403bbb43cb44.tar.gz
gentoo-2-36fffa4854cd2671c8fcc39d225c403bbb43cb44.tar.bz2
gentoo-2-36fffa4854cd2671c8fcc39d225c403bbb43cb44.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/libxml/libxml-2.3.0.ebuild')
-rw-r--r--dev-ruby/libxml/libxml-2.3.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/libxml/libxml-2.3.0.ebuild b/dev-ruby/libxml/libxml-2.3.0.ebuild
new file mode 100644
index 000000000000..907357239cc9
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.3.0.ebuild,v 1.1 2012/03/19 06:35:17 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # replace ulimit -n output as it does not work with Ruby 1.9
+ sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
+}