summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-08 16:24:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-08 16:24:02 +0000
commit0199390ada4a97af501b9360d1d455115324dfbf (patch)
treec982a5305fd61858c72739ebebd9a4c7cd30f82d /dev-ruby/libxml
parentalpha/x86 stable wrt #250221 (diff)
downloadgentoo-2-0199390ada4a97af501b9360d1d455115324dfbf.tar.gz
gentoo-2-0199390ada4a97af501b9360d1d455115324dfbf.tar.bz2
gentoo-2-0199390ada4a97af501b9360d1d455115324dfbf.zip
Version bump.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog8
-rw-r--r--dev-ruby/libxml/libxml-0.9.6.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index b3a40e46dd34..411218822ded 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.19 2008/11/30 11:52:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.20 2008/12/08 16:24:02 flameeyes Exp $
+
+*libxml-0.9.6 (08 Dec 2008)
+
+ 08 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libxml-0.9.6.ebuild:
+ Version bump.
*libxml-0.9.5 (30 Nov 2008)
diff --git a/dev-ruby/libxml/libxml-0.9.6.ebuild b/dev-ruby/libxml/libxml-0.9.6.ebuild
new file mode 100644
index 000000000000..31b6dda5dac5
--- /dev/null
+++ b/dev-ruby/libxml/libxml-0.9.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-0.9.6.ebuild,v 1.1 2008/12/08 16:24:02 flameeyes Exp $
+
+inherit ruby
+
+MY_P=${PN}-ruby-${PV}
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="" # doc
+
+RDEPEND=">=dev-libs/libxml2-2.6.6"
+DEPEND="${RDEPEND}
+ dev-ruby/rake"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ rake extensions || die "rake extensions failed"
+
+ # Does not work on 0.9.6
+ #if use doc; then
+ # rake rdoc || die "rake rdoc failed"
+ #fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ cd "${S}"/ext/libxml
+ ruby_einstall || die "ruby_einstall failed"
+
+ cd "${S}"
+
+ dodoc README CHANGES || die "dodoc failed"
+
+ #if use doc; then
+ # dohtml -r doc/* || die "dohtml failed"
+ #fi
+}