summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-11 06:10:03 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-11 06:10:03 +0000
commit20dca1d21c5a063fcd1550289fd6c3490ca5a007 (patch)
tree95a63480677c984738c857f2122f5154abf9f2fd /dev-ruby/libxml
parentVersion bump. (diff)
downloadgentoo-2-20dca1d21c5a063fcd1550289fd6c3490ca5a007.tar.gz
gentoo-2-20dca1d21c5a063fcd1550289fd6c3490ca5a007.tar.bz2
gentoo-2-20dca1d21c5a063fcd1550289fd6c3490ca5a007.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.2.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 79c2ad7a9648..c17778360107 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.55 2011/09/03 15:47:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.56 2011/09/11 06:10:03 graaff Exp $
+
+*libxml-2.2.2 (11 Sep 2011)
+
+ 11 Sep 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.2.2.ebuild:
+ Version bump.
03 Sep 2011; Raúl Porcel <armin76@gentoo.org> libxml-2.0.5.ebuild:
ia64 stable wrt #370399
diff --git a/dev-ruby/libxml/libxml-2.2.2.ebuild b/dev-ruby/libxml/libxml-2.2.2.ebuild
new file mode 100644
index 000000000000..ae77a8423e2e
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.2.2.ebuild,v 1.1 2011/09/11 06:10:03 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
+}