summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-13 14:23:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-13 14:23:46 +0000
commit500639a5722332fd542f86b142cbb2ea9884f31e (patch)
tree80f70114317fe0e5c21fe1ee4f94fa143d3b68c1 /dev-ruby/libxml
parentppc stable, bug #208873 (diff)
downloadgentoo-2-500639a5722332fd542f86b142cbb2ea9884f31e.tar.gz
gentoo-2-500639a5722332fd542f86b142cbb2ea9884f31e.tar.bz2
gentoo-2-500639a5722332fd542f86b142cbb2ea9884f31e.zip
Version bump, thanks to upstream who fixed rdoc regeneration, now doc USE flag is present.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog9
-rw-r--r--dev-ruby/libxml/libxml-0.9.7.ebuild50
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 411218822ded..08d3cbe2ad44 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.20 2008/12/08 16:24:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.21 2008/12/13 14:23:46 flameeyes Exp $
+
+*libxml-0.9.7 (13 Dec 2008)
+
+ 13 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libxml-0.9.7.ebuild:
+ Version bump, thanks to upstream who fixed rdoc regeneration, now doc USE
+ flag is present.
*libxml-0.9.6 (08 Dec 2008)
diff --git a/dev-ruby/libxml/libxml-0.9.7.ebuild b/dev-ruby/libxml/libxml-0.9.7.ebuild
new file mode 100644
index 000000000000..8731a699c46e
--- /dev/null
+++ b/dev-ruby/libxml/libxml-0.9.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-0.9.7.ebuild,v 1.1 2008/12/13 14:23:46 flameeyes Exp $
+
+inherit ruby
+
+MY_P=${PN}-ruby-${PV}
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.6"
+DEPEND="${RDEPEND}
+ dev-ruby/rake"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ rake extensions || die "rake extensions failed"
+
+ if use doc; then
+ rake rdoc || die "rake rdoc failed"
+ fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ cd "${S}"/ext/libxml
+ ruby_einstall || die "ruby_einstall failed"
+
+ cd "${S}"
+
+ dodoc README CHANGES || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/* || die "dohtml failed"
+ fi
+}