summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-21 11:17:32 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-21 11:17:32 +0000
commit560b570eb826efc39743f9868655bb1cb3025ee7 (patch)
treed00df0830d6ae9dad59c00b95d7b79500d5b58e4 /dev-ruby/libxml
parentVersion bump. (diff)
downloadgentoo-2-560b570eb826efc39743f9868655bb1cb3025ee7.tar.gz
gentoo-2-560b570eb826efc39743f9868655bb1cb3025ee7.tar.bz2
gentoo-2-560b570eb826efc39743f9868655bb1cb3025ee7.zip
Version bump.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.3.3.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 881048e0bb08..491d5e564e48 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.70 2012/05/01 18:24:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.71 2012/07/21 11:17:32 graaff Exp $
+
+*libxml-2.3.3 (21 Jul 2012)
+
+ 21 Jul 2012; Hans de Graaff <graaff@gentoo.org> +libxml-2.3.3.ebuild:
+ Version bump.
01 May 2012; Raúl Porcel <armin76@gentoo.org> libxml-2.0.5.ebuild,
libxml-2.2.1.ebuild, libxml-2.2.2.ebuild, libxml-2.3.0.ebuild,
diff --git a/dev-ruby/libxml/libxml-2.3.3.ebuild b/dev-ruby/libxml/libxml-2.3.3.ebuild
new file mode 100644
index 000000000000..f522758ada87
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.3.3.ebuild,v 1.1 2012/07/21 11:17:32 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="https://github.com/xml4r/libxml-ruby"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # replace ulimit -n output as it does not work with Ruby 1.9
+ sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
+
+ # Avoid test failing due to different semantics in libxml 2.8.
+ # https://github.com/xml4r/libxml-ruby/issues/43
+ sed -i -e '/test_invalid_encoding/,/^ end/ s:^:#:' test/tc_reader.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
+}