summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-24 07:53:52 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-24 07:53:52 +0000
commit1736c1769165ae97dc1c7ef9f51cdee504898000 (patch)
tree0f29245c06a056cc8144717908cf2f06a50bb36e /dev-ruby/maruku/maruku-0.6.1.ebuild
parentMake build log verbose, wrt bug #448140. Thanks to Vicente Olivert Riera for ... (diff)
downloadgentoo-2-1736c1769165ae97dc1c7ef9f51cdee504898000.tar.gz
gentoo-2-1736c1769165ae97dc1c7ef9f51cdee504898000.tar.bz2
gentoo-2-1736c1769165ae97dc1c7ef9f51cdee504898000.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/maruku/maruku-0.6.1.ebuild')
-rw-r--r--dev-ruby/maruku/maruku-0.6.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/maruku/maruku-0.6.1.ebuild b/dev-ruby/maruku/maruku-0.6.1.ebuild
new file mode 100644
index 000000000000..e80d4d8a5d2d
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/maruku-0.6.1.ebuild,v 1.1 2012/12/24 07:53:52 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/changelog.md docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby."
+HOMEPAGE="http://maruku.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/syntax
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/Gem::manage_gems/s:^:#:' \
+ -e '/jamis\.rb/s:^:#:' \
+ Rakefile
+}
+
+each_ruby_test() {
+ # Unit tests fail in various ways. Skip them for now since we never ran
+ # tests for earlier versions at all. No clear upstream to report to...
+ # ${RUBY} -Ilib bin/marutest $(find tests/unittest -name '*.md') || die
+ ${RUBY} -Ilib lib/maruku/tests/new_parser.rb v b || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-tex/latex-unicode if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-tex/listings to enable LaTeX syntax highlighting."
+ elog
+}