summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-04 11:40:35 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-04 11:40:35 +0000
commitb985540615812a8dd09881e1f520d3718205a4f1 (patch)
tree2197b3317092c1961497f27a31f816a3975074ab /dev-ruby/mocha
parentAdd ruby20 support to slot 3.2. (diff)
downloadgentoo-2-b985540615812a8dd09881e1f520d3718205a4f1.tar.gz
gentoo-2-b985540615812a8dd09881e1f520d3718205a4f1.tar.bz2
gentoo-2-b985540615812a8dd09881e1f520d3718205a4f1.zip
Add ruby20 and ruby21 support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/mocha')
-rw-r--r--dev-ruby/mocha/ChangeLog9
-rw-r--r--dev-ruby/mocha/mocha-0.10.5-r2.ebuild51
-rw-r--r--dev-ruby/mocha/mocha-0.11.4-r1.ebuild52
3 files changed, 111 insertions, 1 deletions
diff --git a/dev-ruby/mocha/ChangeLog b/dev-ruby/mocha/ChangeLog
index 2cd6fab13568..7fe69aefaa46 100644
--- a/dev-ruby/mocha/ChangeLog
+++ b/dev-ruby/mocha/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/mocha
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.103 2014/04/26 09:47:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/ChangeLog,v 1.104 2014/05/04 11:40:35 mrueg Exp $
+
+*mocha-0.11.4-r1 (04 May 2014)
+*mocha-0.10.5-r2 (04 May 2014)
+
+ 04 May 2014; Manuel Rüger <mrueg@gentoo.org> +mocha-0.10.5-r2.ebuild,
+ +mocha-0.11.4-r1.ebuild, mocha-0.10.5-r1.ebuild:
+ Add ruby20 and ruby21 support.
26 Apr 2014; Hans de Graaff <graaff@gentoo.org> mocha-0.14.0.ebuild:
Add ruby21.
diff --git a/dev-ruby/mocha/mocha-0.10.5-r2.ebuild b/dev-ruby/mocha/mocha-0.10.5-r2.ebuild
new file mode 100644
index 000000000000..638211b6104b
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.10.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.10.5-r2.ebuild,v 1.1 2014/05/04 11:40:35 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://mocha.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0.10"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/coderay )"
+
+ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+
+ # Use syntax that works with all versions of coderay
+ sed -i -e 's/html.div/html(:wrap => :div)/' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rake examples || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*.rb || die
+}
diff --git a/dev-ruby/mocha/mocha-0.11.4-r1.ebuild b/dev-ruby/mocha/mocha-0.11.4-r1.ebuild
new file mode 100644
index 000000000000..a69aabfffdf0
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.11.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.11.4-r1.ebuild,v 1.1 2014/05/04 11:40:35 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC="yardoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://gofreerange.com/mocha/docs/"
+
+LICENSE="MIT"
+SLOT="0.11"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )"
+
+ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rake examples || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/unit/* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*.rb || die
+}