summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-30 15:48:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-30 15:48:49 +0000
commit94ab2f63be96de4b774a01acbc44e0b413261d52 (patch)
tree850728e1d3a29ee90e5f650d9a9fd10827b2ce68 /dev-ruby/nokogiri
parentStable on amd64. Per bug #330357 (diff)
downloadgentoo-2-94ab2f63be96de4b774a01acbc44e0b413261d52.tar.gz
gentoo-2-94ab2f63be96de4b774a01acbc44e0b413261d52.tar.bz2
gentoo-2-94ab2f63be96de4b774a01acbc44e0b413261d52.zip
Version bump (upstream fixed 1.9.2 in a different way).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog8
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 53820c93bf49..db9e7f213785 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.33 2010/07/30 15:20:50 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.34 2010/07/30 15:48:49 flameeyes Exp $
+
+*nokogiri-1.4.3.1 (30 Jul 2010)
+
+ 30 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +nokogiri-1.4.3.1.ebuild:
+ Version bump (upstream fixed 1.9.2 in a different way).
30 Jul 2010; Jeremy Olexa <darkside@gentoo.org> nokogiri-1.4.2.ebuild:
Add prefix keywords, bug 330283
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild
new file mode 100644
index 000000000000..87df6039bb31
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.3.1.ebuild,v 1.1 2010/07/30 15:48:49 flameeyes Exp $
+
+EAPI=2
+
+# jruby → needs weakling for testing , will add back in a bit
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
+HOMEPAGE="http://nokogiri.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="ffi"
+
+RDEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+DEPEND="${DEPEND}
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+# The tests require _minitest_, not the virtual; what is shipped with
+# Ruby 1.9 is *not* enough, unfortunately
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/rexical
+ dev-ruby/hoe
+ test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
+
+# USE_RUBY=jruby \
+# ruby_add_bdepend "test? ( dev-ruby/weakling )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ Rakefile || die
+}
+
+nokogiri_ffi() {
+ [[ $(basename ${RUBY}) == "jruby" ]] || use ffi
+}
+
+each_ruby_configure() {
+ nokogiri_ffi && return
+ ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/generated_tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/generated_tokenizer.rb || die "rexical failed"
+ fi
+
+ nokogiri_ffi && return
+ emake -Cext/${PN} \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}.so lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ nokogiri_ffi && export NOKOGIRI_FFI=yes
+ each_fakegem_test
+}