summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-03 03:41:17 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-03 03:41:17 +0000
commit93bb4f693c8320f8ee1b415ac92457cd96024d72 (patch)
treed4172154cd03602ea9ee9892cba52891bf8e3167 /dev-ruby/oauth2
parentCleanup old. (diff)
downloadgentoo-2-93bb4f693c8320f8ee1b415ac92457cd96024d72.tar.gz
gentoo-2-93bb4f693c8320f8ee1b415ac92457cd96024d72.tar.bz2
gentoo-2-93bb4f693c8320f8ee1b415ac92457cd96024d72.zip
Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-0.5.2.ebuild35
-rw-r--r--dev-ruby/oauth2/oauth2-0.8.0.ebuild38
-rw-r--r--dev-ruby/oauth2/oauth2-0.9.1.ebuild35
4 files changed, 5 insertions, 110 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index e087bc84130e..19d808edc3f9 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.17 2013/07/19 06:36:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.18 2013/11/03 03:41:17 mrueg Exp $
+
+ 03 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -oauth2-0.5.2.ebuild,
+ -oauth2-0.8.0.ebuild, -oauth2-0.9.1.ebuild:
+ Cleanup old.
*oauth2-0.9.2 (19 Jul 2013)
@@ -82,4 +86,3 @@
+oauth2-0.0.8.ebuild, +metadata.xml:
Initial impor of the OAuth2 gem, to use the new Facebook authentication
APIs.
-
diff --git a/dev-ruby/oauth2/oauth2-0.5.2.ebuild b/dev-ruby/oauth2/oauth2-0.5.2.ebuild
deleted file mode 100644
index 67b54a40e04c..000000000000
--- a/dev-ruby/oauth2/oauth2-0.5.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.5.2.ebuild,v 1.1 2012/04/18 13:38:14 graaff Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.7.4 >=dev-ruby/multi_json-1.0.3"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rspec spec || die
-}
diff --git a/dev-ruby/oauth2/oauth2-0.8.0.ebuild b/dev-ruby/oauth2/oauth2-0.8.0.ebuild
deleted file mode 100644
index e5e90ed9ab7a..000000000000
--- a/dev-ruby/oauth2/oauth2-0.8.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.8.0.ebuild,v 1.2 2012/11/25 19:28:30 tomka Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8
- >=dev-ruby/httpauth-0.1
- >=dev-ruby/jwt-0.1.4
- >=dev-ruby/multi_json-1.0.3
- >=dev-ruby/rack-1.2"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
-
-all_ruby_prepare() {
- rm .rspec || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec spec || die
-}
diff --git a/dev-ruby/oauth2/oauth2-0.9.1.ebuild b/dev-ruby/oauth2/oauth2-0.9.1.ebuild
deleted file mode 100644
index f998f699e3e7..000000000000
--- a/dev-ruby/oauth2/oauth2-0.9.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.9.1.ebuild,v 1.1 2013/04/13 06:23:50 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8
- >=dev-ruby/httpauth-0.1
- >=dev-ruby/jwt-0.1.4
- >=dev-ruby/multi_json-1.0.3
- >=dev-ruby/multi_xml-0.5
- >=dev-ruby/rack-1.2"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec spec || die
-}