summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-19 07:01:54 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-19 07:01:54 +0000
commitd99d3a360606e631daa79a29cb6eec6bb49c5670 (patch)
treeabc986ffb95e090ccc74d8dc4bbda9435b4ca2db /dev-ruby/ohai
parentBump for #477348 with jbergstroem's patches for #475354 (diff)
downloadgentoo-2-d99d3a360606e631daa79a29cb6eec6bb49c5670.tar.gz
gentoo-2-d99d3a360606e631daa79a29cb6eec6bb49c5670.tar.bz2
gentoo-2-d99d3a360606e631daa79a29cb6eec6bb49c5670.zip
Version bump. Run as many specs as possible.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ohai')
-rw-r--r--dev-ruby/ohai/ChangeLog7
-rw-r--r--dev-ruby/ohai/ohai-6.16.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
index 8356cab282f6..98a972d0af1c 100644
--- a/dev-ruby/ohai/ChangeLog
+++ b/dev-ruby/ohai/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ohai
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.16 2013/06/20 07:10:51 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.17 2013/07/19 07:01:54 graaff Exp $
+
+*ohai-6.16.0 (19 Jul 2013)
+
+ 19 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ohai-6.16.0.ebuild:
+ Version bump. Run as many specs as possible.
20 Jun 2013; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
remove myself from maintainers
diff --git a/dev-ruby/ohai/ohai-6.16.0.ebuild b/dev-ruby/ohai/ohai-6.16.0.ebuild
new file mode 100644
index 000000000000..1cc5f8793408
--- /dev/null
+++ b/dev-ruby/ohai/ohai-6.16.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-6.16.0.ebuild,v 1.1 2013/07/19 07:01:54 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/chef/Ohai"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/ipaddress
+ dev-ruby/yajl-ruby
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ dev-ruby/mixlib-shellout
+ >=dev-ruby/systemu-2.2.0"
+
+all_ruby_prepare() {
+ rm Gemfile .rspec || die
+ # Be more lenient to work with versions of systemu that we have in
+ # the tree.
+ sed -i -e 's/~> 2.2.0/>= 2.2.0/' ohai.gemspec || die
+
+ # Remove the Darwin-specific tests that require additional
+ # dependencies.
+ rm -rf spec/unit/plugins/darwin || die
+
+ # Avoid the ruby plugin tests because these always execute the
+ # system ruby, rather than the current ruby.
+ rm -rf spec/unit/plugins/ruby_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman docs/man/man1/ohai.1
+}