summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-04 07:15:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-04 07:15:46 +0000
commit84f0024a22323c3f84d2335be026eccf7d4e29cc (patch)
tree2e38dc6aecd2c28b28b80660163e0c9d40417089 /dev-ruby/pg
parentRemove version with broken gemspec. (diff)
downloadgentoo-2-84f0024a22323c3f84d2335be026eccf7d4e29cc.tar.gz
gentoo-2-84f0024a22323c3f84d2335be026eccf7d4e29cc.tar.bz2
gentoo-2-84f0024a22323c3f84d2335be026eccf7d4e29cc.zip
Version bump. Also fix bug 429424 for 0.13.2 and 0.14.0.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog8
-rw-r--r--dev-ruby/pg/pg-0.13.2.ebuild4
-rw-r--r--dev-ruby/pg/pg-0.14.0.ebuild66
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 5ead3601ec45..18667af4c9a8 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.51 2012/05/01 18:24:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.52 2012/08/04 07:15:46 graaff Exp $
+
+*pg-0.14.0 (04 Aug 2012)
+
+ 04 Aug 2012; Hans de Graaff <graaff@gentoo.org> pg-0.13.2.ebuild,
+ +pg-0.14.0.ebuild:
+ Version bump. Also fix bug 429424 for 0.13.2 and 0.14.0.
01 May 2012; Raúl Porcel <armin76@gentoo.org> pg-0.11.0.ebuild,
pg-0.12.2.ebuild, pg-0.13.2.ebuild:
diff --git a/dev-ruby/pg/pg-0.13.2.ebuild b/dev-ruby/pg/pg-0.13.2.ebuild
index a454228a0ada..c6c28f9fcb0a 100644
--- a/dev-ruby/pg/pg-0.13.2.ebuild
+++ b/dev-ruby/pg/pg-0.13.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.13.2.ebuild,v 1.2 2012/05/01 18:24:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.13.2.ebuild,v 1.3 2012/08/04 07:15:46 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ree18 ruby19"
@@ -41,6 +41,8 @@ all_ruby_prepare() {
-e '/Rakefile.cross/s:^:#:' \
-e '/ExtensionTask/,/^end$/ s:^:#:' \
Rakefile || die
+
+ sed -i -e '18i require "socket"' spec/pg/connection_spec.rb || die
}
each_ruby_configure() {
diff --git a/dev-ruby/pg/pg-0.14.0.ebuild b/dev-ruby/pg/pg-0.14.0.ebuild
new file mode 100644
index 000000000000..ae6fa94d5489
--- /dev/null
+++ b/dev-ruby/pg/pg-0.14.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.14.0.ebuild,v 1.1 2012/08/04 07:15:46 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="redocs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="http://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ dev-db/postgresql-base"
+DEPEND="${DEPEND}
+ dev-db/postgresql-base
+ test? ( dev-db/postgresql-server )"
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ || ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+
+ sed -i -e '18i require "socket"' spec/pg/connection_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/*.so lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}