summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-13 12:56:58 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-13 12:56:58 +0000
commitb1cb013e7a24170c2f6123f5848e7a5ea96be59b (patch)
tree9686b1a33f892cd189406f6eca188af6281becf1 /dev-ruby/rack-protection
parentCleanup. (diff)
downloadgentoo-2-b1cb013e7a24170c2f6123f5848e7a5ea96be59b.tar.gz
gentoo-2-b1cb013e7a24170c2f6123f5848e7a5ea96be59b.tar.bz2
gentoo-2-b1cb013e7a24170c2f6123f5848e7a5ea96be59b.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/ChangeLog8
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.0.ebuild24
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-ruby/rack-protection/ChangeLog b/dev-ruby/rack-protection/ChangeLog
index e515c140696f..88a04e4e4833 100644
--- a/dev-ruby/rack-protection/ChangeLog
+++ b/dev-ruby/rack-protection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rack-protection
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.13 2013/04/13 12:54:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.14 2013/04/13 12:56:58 graaff Exp $
+
+*rack-protection-1.5.0 (13 Apr 2013)
+
+ 13 Apr 2013; Hans de Graaff <graaff@gentoo.org>
+ +rack-protection-1.5.0.ebuild:
+ Version bump.
13 Apr 2013; Hans de Graaff <graaff@gentoo.org>
-rack-protection-1.2.0.ebuild, -rack-protection-1.3.1.ebuild:
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.0.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.0.ebuild
new file mode 100644
index 000000000000..0f01e488ad3c
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/rack-protection-1.5.0.ebuild,v 1.1 2013/04/13 12:56:58 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks."
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"