summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 07:37:24 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 07:37:24 +0000
commit40e9708c298aabae3a4021af2783bcb8f5417788 (patch)
tree10a35aadc6f4c1f262c5e2e8bb22d4545399d8fa /dev-ruby/rails
parent[media-sound/google-musicmanager] import from cj-overlay (diff)
downloadgentoo-2-40e9708c298aabae3a4021af2783bcb8f5417788.tar.gz
gentoo-2-40e9708c298aabae3a4021af2783bcb8f5417788.tar.bz2
gentoo-2-40e9708c298aabae3a4021af2783bcb8f5417788.zip
Version bump for Rails 3.0.10
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.0.10.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 6b5877145600..e5539e9947ac 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.204 2011/09/09 12:23:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.205 2011/09/28 07:37:24 graaff Exp $
+
+*rails-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org> rails-3.0.9.ebuild:
Marked ~sparc-solaris
diff --git a/dev-ruby/rails/rails-3.0.10.ebuild b/dev-ruby/rails/rails-3.0.10.ebuild
new file mode 100644
index 000000000000..2f00d54531a9
--- /dev/null
+++ b/dev-ruby/rails/rails-3.0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.0.10.ebuild,v 1.1 2011/09/28 07:37:24 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.16"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1.0*
+ ~dev-ruby/railties-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}