summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 09:33:45 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 09:33:45 +0000
commit9475d1a837af7060784cb7e1434305ced83f4961 (patch)
tree766efdf0be546eb4a8fb45caf05d2b3ba667eee2 /dev-ruby/rails
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-9475d1a837af7060784cb7e1434305ced83f4961.tar.gz
gentoo-2-9475d1a837af7060784cb7e1434305ced83f4961.tar.bz2
gentoo-2-9475d1a837af7060784cb7e1434305ced83f4961.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.18.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 2585d5befeea..3256dabf064a 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.262 2013/03/27 13:28:39 moult Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.263 2013/03/30 09:33:45 graaff Exp $
+
+*rails-2.3.18 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +rails-2.3.18.ebuild:
+ Version bump for security bug 462452.
27 Mar 2013; Dion Moult <moult@gentoo.org> -rails-3.0.20.ebuild:
Remove dev-ruby/rails:3.0 due to lack of upstream support
diff --git a/dev-ruby/rails/rails-2.3.18.ebuild b/dev-ruby/rails/rails-2.3.18.ebuild
new file mode 100644
index 000000000000..fffbfb9f75e1
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.18.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.18.ebuild,v 1.1 2013/03/30 09:33:45 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ dev-ruby/rdoc
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die "Could not remove reference to unavailable documentation template."
+
+ # Create the documentation that we create on the fly in a separate
+ # directory, since we need to install the doc directory for the
+ # rails script.
+ sed -i -e "s/rdoc_dir = 'doc'/rdoc_dir = 'rdoc'/" Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ pushd rdoc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}