summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-19 08:05:40 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-19 08:05:40 +0000
commit38c6718ba1835d29336f3cc445c76c894f29c917 (patch)
tree51c6547a4d235875482bbd41a8997e75bbc71bfc /dev-ruby/railties
parentVersion bump for security bug 501750. (diff)
downloadgentoo-2-38c6718ba1835d29336f3cc445c76c894f29c917.tar.gz
gentoo-2-38c6718ba1835d29336f3cc445c76c894f29c917.tar.bz2
gentoo-2-38c6718ba1835d29336f3cc445c76c894f29c917.zip
Version bump for security bug 501750.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/railties')
-rw-r--r--dev-ruby/railties/ChangeLog7
-rw-r--r--dev-ruby/railties/railties-4.0.3.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-ruby/railties/ChangeLog b/dev-ruby/railties/ChangeLog
index 6db680be305b..fd149e8ba989 100644
--- a/dev-ruby/railties/ChangeLog
+++ b/dev-ruby/railties/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/railties
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.67 2014/02/19 07:27:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.68 2014/02/19 08:05:40 graaff Exp $
+
+*railties-4.0.3 (19 Feb 2014)
+
+ 19 Feb 2014; Hans de Graaff <graaff@gentoo.org> +railties-4.0.3.ebuild:
+ Version bump for security bug 501750.
*railties-3.2.17 (19 Feb 2014)
diff --git a/dev-ruby/railties/railties-4.0.3.ebuild b/dev-ruby/railties/railties-4.0.3.ebuild
new file mode 100644
index 000000000000..43dfaa6ed41b
--- /dev/null
+++ b/dev-ruby/railties/railties-4.0.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-4.0.3.ebuild,v 1.1 2014/02/19 08:05:40 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+RDEPEND+=">=app-admin/eselect-rails-0.19"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/thor-0.18.1
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ )"
+
+all_ruby_prepare() {
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+ sed -i -e '1igem "minitest", "~>4.0"' test/abstract_unit.rb || die
+
+ # Also allow rdoc 4.x
+ sed -i -e 's/~> 3.4/>= 3.4/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}