summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-06 05:48:32 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-06 05:48:32 +0000
commit0a1f34e7dff0faaf0a3d89dd0b67a681c89e03e2 (patch)
treeb1e18c263a5552ac2dd23071b24e75d1b0e1acf7 /dev-ruby/rb-inotify
parentUpdate mime db's. (diff)
downloadgentoo-2-0a1f34e7dff0faaf0a3d89dd0b67a681c89e03e2.tar.gz
gentoo-2-0a1f34e7dff0faaf0a3d89dd0b67a681c89e03e2.tar.bz2
gentoo-2-0a1f34e7dff0faaf0a3d89dd0b67a681c89e03e2.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/ChangeLog7
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.8.8.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/rb-inotify/ChangeLog b/dev-ruby/rb-inotify/ChangeLog
index 83e2aeb422d9..53c13c876aa3 100644
--- a/dev-ruby/rb-inotify/ChangeLog
+++ b/dev-ruby/rb-inotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rb-inotify
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.5 2011/08/14 10:17:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.6 2011/10/06 05:48:32 graaff Exp $
+
+*rb-inotify-0.8.8 (06 Oct 2011)
+
+ 06 Oct 2011; Hans de Graaff <graaff@gentoo.org> +rb-inotify-0.8.8.ebuild:
+ Version bump.
14 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
rb-inotify-0.8.6-r1.ebuild:
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.8.8.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.8.8.ebuild
new file mode 100644
index 000000000000..877994e5ff05
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.8.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.8.8.ebuild,v 1.1 2011/10/06 05:48:32 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI."
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # jruby has a native implementation and should not list ffi
+ # in the gemspec.
+ sed -i -e '/ffi/d' rb-inotify.gemspec || die
+ ;;
+ *)
+ ;;
+ esac
+}