summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:10:00 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2011-06-18 10:10:00 +0000
commit28ae97f8442e503d2e80c756fe7ef021a787eab5 (patch)
tree39d2bf4ca23e40f590793e56cd43f5c3a0887369 /dev-ruby/rcsparse
parentAdded "|| die" to few commands to prevent possible problems (diff)
downloadgentoo-2-28ae97f8442e503d2e80c756fe7ef021a787eab5.tar.gz
gentoo-2-28ae97f8442e503d2e80c756fe7ef021a787eab5.tar.bz2
gentoo-2-28ae97f8442e503d2e80c756fe7ef021a787eab5.zip
Added "|| die" to few commands to prevent possible problems
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rcsparse')
-rw-r--r--dev-ruby/rcsparse/ChangeLog6
-rw-r--r--dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-ruby/rcsparse/ChangeLog b/dev-ruby/rcsparse/ChangeLog
index 07637a854bb5..13b8ad28cd5c 100644
--- a/dev-ruby/rcsparse/ChangeLog
+++ b/dev-ruby/rcsparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rcsparse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/ChangeLog,v 1.2 2011/06/18 10:01:46 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/ChangeLog,v 1.3 2011/06/18 10:10:00 sochotnicky Exp $
+
+ 18 Jun 2011; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ rcsparse-0_pre45-r1.ebuild:
+ Added "|| die" to few commands to prevent possible problems
*rcsparse-0_pre45-r1 (18 Jun 2011)
diff --git a/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
index 2b996dc75296..49736722cef5 100644
--- a/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
+++ b/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild,v 1.1 2011/06/18 10:01:46 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcsparse/rcsparse-0_pre45-r1.ebuild,v 1.2 2011/06/18 10:10:00 sochotnicky Exp $
EAPI=4
@@ -32,8 +32,8 @@ src_prepare() {
# this is a workaround because combination of ruby-ng and mercurial is
# not working correctly for unpacking
for rubyv in ${USE_RUBY} all;do
- mkdir "${WORKDIR}/${rubyv}"
- cp -prl "${S}" "${WORKDIR}/${rubyv}/${RUBY_S}"
+ mkdir "${WORKDIR}/${rubyv}" || die
+ cp -prl "${S}" "${WORKDIR}/${rubyv}/${RUBY_S}" || die
done
}