summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-29 18:38:44 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-29 18:38:44 +0000
commit5efa112b23376179d8981e78b006753fbba1398a (patch)
tree52a14570033b524e9a50c4adcd04ac36f6ba7543 /dev-ruby/rdiscount
parentFix comment. Remove extraneous whitespace. (diff)
downloadgentoo-2-5efa112b23376179d8981e78b006753fbba1398a.tar.gz
gentoo-2-5efa112b23376179d8981e78b006753fbba1398a.tar.bz2
gentoo-2-5efa112b23376179d8981e78b006753fbba1398a.zip
Version bump, thanks to mrueg in the ruby overlay.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/ChangeLog7
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.1.6.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/rdiscount/ChangeLog b/dev-ruby/rdiscount/ChangeLog
index 84db80094d24..fde395096785 100644
--- a/dev-ruby/rdiscount/ChangeLog
+++ b/dev-ruby/rdiscount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rdiscount
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.17 2013/01/15 05:02:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.18 2013/05/29 18:38:44 graaff Exp $
+
+*rdiscount-2.1.6 (29 May 2013)
+
+ 29 May 2013; Hans de Graaff <graaff@gentoo.org> +rdiscount-2.1.6.ebuild:
+ Version bump, thanks to mrueg in the ruby overlay.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> rdiscount-1.6.8-r1.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/rdiscount/rdiscount-2.1.6.ebuild b/dev-ruby/rdiscount/rdiscount-2.1.6.ebuild
new file mode 100644
index 000000000000..dda7ae4eafa4
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-2.1.6.ebuild,v 1.1 2013/05/29 18:38:44 graaff Exp $
+
+EAPI=5
+
+# Has a native extension without jruby support.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="http://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}