summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-14 09:26:34 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-14 09:26:34 +0000
commit7ee54e95e77d813c1ddf76594fbd9edf282be323 (patch)
tree7d0d9fd00333948f5b3a3e85414cb832a61229e1 /dev-ruby/rdoc
parentdev-lang/idb: Version Bump (diff)
downloadgentoo-2-7ee54e95e77d813c1ddf76594fbd9edf282be323.tar.gz
gentoo-2-7ee54e95e77d813c1ddf76594fbd9edf282be323.tar.bz2
gentoo-2-7ee54e95e77d813c1ddf76594fbd9edf282be323.zip
Install rdoc20 wrapper needed for eselecting ruby. Fixes bug 476694. Thanks to cmuelle8 for the initial patch.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/ChangeLog8
-rw-r--r--dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild98
2 files changed, 105 insertions, 1 deletions
diff --git a/dev-ruby/rdoc/ChangeLog b/dev-ruby/rdoc/ChangeLog
index a67b1732c83d..6b02ac98f3bf 100644
--- a/dev-ruby/rdoc/ChangeLog
+++ b/dev-ruby/rdoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rdoc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.113 2013/07/07 08:09:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.114 2013/07/14 09:26:34 graaff Exp $
+
+*rdoc-4.0.1-r1 (14 Jul 2013)
+
+ 14 Jul 2013; Hans de Graaff <graaff@gentoo.org> +rdoc-4.0.1-r1.ebuild:
+ Install rdoc20 wrapper needed for eselecting ruby. Fixes bug 476694. Thanks
+ to cmuelle8 for the initial patch.
07 Jul 2013; Hans de Graaff <graaff@gentoo.org> rdoc-4.0.1.ebuild:
Add ruby20 support.
diff --git a/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild b/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..7da4054d9745
--- /dev/null
+++ b/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-4.0.1-r1.ebuild,v 1.1 2013/07/14 09:26:34 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
+HOMEPAGE="https://github.com/rdoc/rdoc/"
+
+LICENSE="Ruby MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ dev-ruby/racc
+ test? (
+ virtual/ruby-minitest
+ )"
+
+ruby_add_rdepend "=dev-ruby/json-1* >=dev-ruby/json-1.4"
+
+# This ebuild replaces rdoc in ruby-1.9.2 and later.
+# ruby 1.8.6 is no longer supported.
+RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? (
+ >=dev-lang/ruby-1.9.2:1.9
+ )
+ ruby_targets_ruby18? (
+ >=dev-lang/ruby-1.8.7:1.8
+ )"
+
+all_ruby_prepare() {
+ # Other packages also have use for a nonexistent directory, bug 321059
+ sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/test_rdoc*.rb || die
+
+ # Remove unavailable and unneeded isolate plugin for Hoe
+ sed -i -e '/isolate/d' Rakefile || die
+
+ # Remove licenses line from Hoe definitions so we also use older versions.
+ sed -i -e '/licenses/ s:^:#:' Rakefile || die
+
+ epatch "${FILESDIR}/${PN}-3.0.1-bin-require.patch"
+
+ # Remove test that is depending on the locale, which we can't garantuee.
+ sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
+
+ # Remove test depending on FEATURES=userpriv, bug 361959
+ sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/test_rdoc_options.rb || die
+
+ # Avoid the generate rule since it doesn't work on jruby, see below.
+ sed -i -e '/:generate/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ ruby -Ilib -S bin/rdoc || die
+ fi
+}
+
+each_ruby_compile() {
+ # Generate the file inline here since the Rakefile confuses jruby
+ # into a circular dependency.
+ for file in lib/rdoc/rd/block_parser lib/rdoc/rd/inline_parser ; do
+ ${RUBY} -S racc -l -o ${file}.rb ${file}.ry || die
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for bin in rdoc ri; do
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
+
+ for version in 19 20; do
+ if use ruby_targets_ruby${version}; then
+ ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
+ sed -i -e "1s/env ruby/ruby${version}/" \
+ "${ED}/usr/bin/${bin}${version}" || die
+ fi
+ done
+ done
+}