summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
commite9e5400092458ce2ac5e8e8e392f09fdfc7bcde8 (patch)
tree28014ea8be64a846251a7462553db444823ad771 /dev-ruby/rdtool
parentInitial import of Ruby, the OO scripting lang, into the portage tree. (diff)
downloadgentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.gz
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.bz2
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.zip
Initial import of a slew or Ruby modules. This is the base for
generating RD (similar to Perl's POD) files. Hey, we might as well start with the ability to document the code we write. 8) The modules installed are: amstd -- standard libraries for Ruby optparse -- an option parser racc -- lexical parser strscan -- fast string formatter/scanner rdtool -- RD doc formatter
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/files/digest-rdtool-0.6.61
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rdtool/files/digest-rdtool-0.6.6 b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
new file mode 100644
index 000000000000..51689b7bcd91
--- /dev/null
+++ b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
@@ -0,0 +1 @@
+MD5 36faf95bd070d560cf752b095ad4ea21 rdtool-0.6.6.tar.gz
diff --git a/dev-ruby/rdtool/rdtool-0.6.6.ebuild b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
new file mode 100644
index 000000000000..1ff00901a518
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.6.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Fast string scanning library for Ruby"
+SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${A}"
+HOMEPAGE="http://www2.pos.to/~tosh/ruby/rdtool/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/racc-1.2.4
+ >=dev-ruby/strscan-0.5.8
+ >=dev-ruby/optparse-0.7.5"
+
+src_compile() {
+ cd ${S}
+ try ruby rdtoolconf.rb
+ try make
+}
+
+src_install () {
+ cd ${S}
+ chmod 755 rd2
+ dobin rd2
+
+ cd ${S}/rd
+ insinto /usr/lib/ruby/site_ruby/1.6/rd
+ doins dot.rd2rc *.rb
+}