summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-15 12:25:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-15 12:25:22 +0000
commit8953d37909195f24f53d143a582e2c61998c23b8 (patch)
tree0a8deeec7a6a111621dfc2d57c2a21ca73770976 /dev-ruby/right_aws
parentVersion bump. (diff)
downloadgentoo-2-8953d37909195f24f53d143a582e2c61998c23b8.tar.gz
gentoo-2-8953d37909195f24f53d143a582e2c61998c23b8.tar.bz2
gentoo-2-8953d37909195f24f53d143a582e2c61998c23b8.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/right_aws')
-rw-r--r--dev-ruby/right_aws/ChangeLog9
-rw-r--r--dev-ruby/right_aws/right_aws-3.0.4.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ruby/right_aws/ChangeLog b/dev-ruby/right_aws/ChangeLog
index 46ac795b2644..8ab03fcd2fb0 100644
--- a/dev-ruby/right_aws/ChangeLog
+++ b/dev-ruby/right_aws/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/right_aws
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_aws/ChangeLog,v 1.1 2010/01/28 00:26:55 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_aws/ChangeLog,v 1.2 2012/06/15 12:25:22 flameeyes Exp $
+
+*right_aws-3.0.4 (15 Jun 2012)
+
+ 15 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> +right_aws-3.0.4.ebuild:
+ Version bump.
*right_aws-1.10.0 (28 Jan 2010)
diff --git a/dev-ruby/right_aws/right_aws-3.0.4.ebuild b/dev-ruby/right_aws/right_aws-3.0.4.ebuild
new file mode 100644
index 000000000000..bee4c1b9f985
--- /dev/null
+++ b/dev-ruby/right_aws/right_aws-3.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_aws/right_aws-3.0.4.ebuild,v 1.1 2012/06/15 12:25:22 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A robust, fast, and secure interface to Amazon EC2, EBS, S3, SQS, SDB, and CloudFront."
+HOMEPAGE="http://www.rightscale.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Tests require you to set up Amazon AWS access so we have no way to
+# handle this from within the ebuild :(
+RESTRICT="test"
+
+ruby_add_rdepend '>=dev-ruby/right_http_connection-1.2.5 dev-ruby/uuidtools'
+
+all_ruby_prepare() {
+ # by default the Rakefile will require rcovtask from rcov to allow
+ # coverage testing; since we don't care about that we'll just be
+ # ignoring it for now.
+ sed -i \
+ -e '/rcovtask/s:^:#:' \
+ Rakefile || die
+}