summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-07 06:27:11 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-07 06:27:11 +0000
commit44865815315b3a66ea9b0c49b5b4efb9bf936874 (patch)
tree77dacd99cbfcb8b1ccd9b3ec9de3939679aa84ae /dev-ruby/rspec-core
parentVersion bump. (diff)
downloadgentoo-2-44865815315b3a66ea9b0c49b5b4efb9bf936874.tar.gz
gentoo-2-44865815315b3a66ea9b0c49b5b4efb9bf936874.tar.bz2
gentoo-2-44865815315b3a66ea9b0c49b5b4efb9bf936874.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/ChangeLog7
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.99.1.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 7dfadb0de074..21b664c2df43 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.69 2014/06/16 15:41:14 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.70 2014/07/07 06:27:10 graaff Exp $
+
+*rspec-core-2.99.1 (07 Jul 2014)
+
+ 07 Jul 2014; Hans de Graaff <graaff@gentoo.org> +rspec-core-2.99.1.ebuild:
+ Version bump.
16 Jun 2014; Tobias Klausmann <klausman@gentoo.org>
rspec-core-2.14.8-r1.ebuild:
diff --git a/dev-ruby/rspec-core/rspec-core-2.99.1.ebuild b/dev-ruby/rspec-core/rspec-core-2.99.1.ebuild
new file mode 100644
index 000000000000..e485a8452a17
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.99.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.99.1.ebuild,v 1.1 2014/07/07 06:27:11 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-2.14.0:2
+ >=dev-ruby/rspec-mocks-2.99.0:2
+ )"
+
+# Skip yard for ruby20 for now since we don't support ruby20 eselected
+# yet and we can't bootstrap otherwise.
+USE_RUBY=${USE_RUBY/ruby20/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/aruba/ s:^:#:' -e '/Aruba/,/}/ s:^:#:' spec/spec_helper.rb || die
+ rm spec/command_line/order_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+
+ case ${RUBY} in
+ *jruby)
+ # Avoid tests specific to jruby but without jruby 1.6 support.
+ sed -e '/JRUBY_VERSION/ s:^:#:' -i spec/rspec/core/filter_manager_spec.rb || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}