summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-20 06:45:56 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-20 06:45:56 +0000
commitd3f191e2513a7feeba8706a21e3c1d7949d1f452 (patch)
tree5b879f0a22401f169a3dbd48e317727656d10df2 /dev-ruby/rspec-core
parentVersion bump. (diff)
downloadgentoo-2-d3f191e2513a7feeba8706a21e3c1d7949d1f452.tar.gz
gentoo-2-d3f191e2513a7feeba8706a21e3c1d7949d1f452.tar.bz2
gentoo-2-d3f191e2513a7feeba8706a21e3c1d7949d1f452.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/ChangeLog7
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index f2655bab889e..e20b6f4607da 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.55 2013/07/20 06:13:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.56 2013/07/20 06:45:56 graaff Exp $
+
+*rspec-core-2.14.3 (20 Jul 2013)
+
+ 20 Jul 2013; Hans de Graaff <graaff@gentoo.org> +rspec-core-2.14.3.ebuild:
+ Version bump.
20 Jul 2013; Hans de Graaff <graaff@gentoo.org> -rspec-core-2.6.4-r1.ebuild:
Cleanup.
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild
new file mode 100644
index 000000000000..e61ea14ca8cd
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild,v 1.1 2013/07/20 06:45:56 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-2.14.0:2
+ >=dev-ruby/rspec-mocks-2.12.0:2
+ )"
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Remove jruby-specific comparison documents since for us the normal
+ # version passes.
+ cp spec/rspec/core/formatters/text_mate_formatted-1.8.7.html spec/rspec/core/formatters/text_mate_formatted-1.8.7-jruby.html|| die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
+ rm spec/command_line/order_spec.rb || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}