summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:21:30 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:21:30 +0000
commit881e4bd2b6428e160c6fd75e545d18c07174e5fd (patch)
treec6abcce2b242f2019706ef0b25a85c6f9f23f9ab /dev-ruby/rspec-expectations
parentRevision bump to drop ruby19 from stable version. (diff)
downloadgentoo-2-881e4bd2b6428e160c6fd75e545d18c07174e5fd.tar.gz
gentoo-2-881e4bd2b6428e160c6fd75e545d18c07174e5fd.tar.bz2
gentoo-2-881e4bd2b6428e160c6fd75e545d18c07174e5fd.zip
Revision bump to drop ruby19 from stable version.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild47
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild4
3 files changed, 56 insertions, 3 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 76b097394058..c4a5b97c636b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.18 2011/10/12 17:51:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.19 2011/12/28 08:21:30 graaff Exp $
+
+*rspec-expectations-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ rspec-expectations-2.6.0.ebuild, +rspec-expectations-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
12 Oct 2011; Hans de Graaff <graaff@gentoo.org>
rspec-expectations-2.6.0.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..e5ab1705ccaf
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:21:30 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.4.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
index 2e5e482db244..3a083ac9d14b 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild,v 1.9 2011/10/12 17:51:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild,v 1.10 2011/12/28 08:21:30 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST="none"