summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-28 10:12:04 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-28 10:12:04 +0000
commitea3944b256d562f845c44f07f0d3d1a9cc57c8cf (patch)
treeadf9f3f8daa585ef482407cb45c8a10a4a4852d8 /dev-ruby/rspec-expectations
parentStable for x86, wrt bug #532542 (diff)
downloadgentoo-2-ea3944b256d562f845c44f07f0d3d1a9cc57c8cf.tar.gz
gentoo-2-ea3944b256d562f845c44f07f0d3d1a9cc57c8cf.tar.bz2
gentoo-2-ea3944b256d562f845c44f07f0d3d1a9cc57c8cf.zip
Version bump for rspec 3.x.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.1.2.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 7c1fcd42182f..81671f37686d 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.83 2014/11/25 11:35:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.84 2014/12/28 10:12:04 graaff Exp $
+
+*rspec-expectations-3.1.2 (28 Dec 2014)
+
+ 28 Dec 2014; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-3.1.2.ebuild:
+ Version bump for rspec 3.x.
25 Nov 2014; Manuel Rüger <mrueg@gentoo.org>
rspec-expectations-2.14.5-r1.ebuild, rspec-expectations-2.14.5.ebuild,
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.1.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.1.2.ebuild
new file mode 100644
index 000000000000..87eb262a8eef
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-3.1.2.ebuild,v 1.1 2014/12/28 10:12:04 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.0.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ #
+ sed -i -e '1irequire "spec_helper"' spec/rspec/expectations/configuration_spec.rb || die
+
+ # Avoid a weird, and failing, test testing already installed code.
+ sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
+}