summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-03 17:53:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-03 17:53:46 +0000
commit2fdb0cb2a7484122553af00dce7d9b09d15553a8 (patch)
tree0069ad88092c331bdd9dc79b71a021d5c7a3d692 /dev-ruby/ruby-postgres
parentsci-chemistry/ccpn: Cleaned old, add latest python patches (diff)
downloadgentoo-2-2fdb0cb2a7484122553af00dce7d9b09d15553a8.tar.gz
gentoo-2-2fdb0cb2a7484122553af00dce7d9b09d15553a8.tar.bz2
gentoo-2-2fdb0cb2a7484122553af00dce7d9b09d15553a8.zip
Provide our own gemspec to work around bug 407829.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog6
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index 82fae1b3e783..aec76c332d18 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.41 2012/03/12 18:26:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.42 2012/04/03 17:53:46 graaff Exp $
+
+ 03 Apr 2012; Hans de Graaff <graaff@gentoo.org>
+ ruby-postgres-0.7.9.20080128-r2.ebuild:
+ Provide our own gemspec to work around bug 407829.
12 Mar 2012; Hans de Graaff <graaff@gentoo.org>
-ruby-postgres-0.7.9.20080128-r1.ebuild:
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild
index f0852fd5ba76..f529fc2eedc4 100644
--- a/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild,v 1.6 2011/08/28 19:39:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild,v 1.7 2012/04/03 17:53:46 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18"
@@ -32,6 +32,12 @@ IUSE=""
RDEPEND="${RDEPEND} dev-db/postgresql-base"
DEPEND="${DEPEND} dev-db/postgresql-base"
+all_ruby_prepare() {
+ # Remove yaml metadata so we supply our own gemspec. There are no
+ # ruby dependencies and this might fix bug 407829.
+ rm ../metadata || die
+}
+
each_ruby_configure() {
${RUBY} -Cext extconf.rb || die
}