summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-27 05:51:00 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-27 05:51:00 +0000
commit0742848c0a4dc86d4fd09f77090005c4880222e1 (patch)
tree38faf3fa57be4e767cf9839770cebab3b735ec5a /dev-ruby/ruby-serialport
parentLatest release from upstream. Please note that plugin handling has changed a ... (diff)
downloadgentoo-2-0742848c0a4dc86d4fd09f77090005c4880222e1.tar.gz
gentoo-2-0742848c0a4dc86d4fd09f77090005c4880222e1.tar.bz2
gentoo-2-0742848c0a4dc86d4fd09f77090005c4880222e1.zip
Version bump: bug fixes.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-serialport')
-rw-r--r--dev-ruby/ruby-serialport/ChangeLog8
-rw-r--r--dev-ruby/ruby-serialport/ruby-serialport-1.0.3.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/ruby-serialport/ChangeLog b/dev-ruby/ruby-serialport/ChangeLog
index ed346a3cbe8e..4f938baca257 100644
--- a/dev-ruby/ruby-serialport/ChangeLog
+++ b/dev-ruby/ruby-serialport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-serialport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.11 2010/01/24 00:02:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.12 2010/04/27 05:51:00 graaff Exp $
+
+*ruby-serialport-1.0.3 (27 Apr 2010)
+
+ 27 Apr 2010; Hans de Graaff <graaff@gentoo.org>
+ +ruby-serialport-1.0.3.ebuild:
+ Version bump: bug fixes.
24 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-serialport-1.0.1.ebuild:
diff --git a/dev-ruby/ruby-serialport/ruby-serialport-1.0.3.ebuild b/dev-ruby/ruby-serialport/ruby-serialport-1.0.3.ebuild
new file mode 100644
index 000000000000..abec869da928
--- /dev/null
+++ b/dev-ruby/ruby-serialport/ruby-serialport-1.0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ruby-serialport-1.0.3.ebuild,v 1.1 2010/04/27 05:51:00 graaff Exp $
+
+EAPI="2"
+
+# jruby → uses native library
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+RUBY_FAKEGEM_NAME=${PN/ruby-/}
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake || die
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*.so lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ # don't compress it
+ doins test/miniterm.rb || die
+}