summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-07 13:34:15 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-07 13:34:15 +0000
commit3d29ad76731cb5ac26840a58629e15e05363ab3b (patch)
tree40b470f76016eec52e242006995a19ee4156a87e /dev-ruby/ruby-shadow
parentStable on amd64 wrt bug #300732 (diff)
downloadgentoo-2-3d29ad76731cb5ac26840a58629e15e05363ab3b.tar.gz
gentoo-2-3d29ad76731cb5ac26840a58629e15e05363ab3b.tar.bz2
gentoo-2-3d29ad76731cb5ac26840a58629e15e05363ab3b.zip
Convert to ruby-ng. Add Debian patch to fix #302798.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-shadow')
-rw-r--r--dev-ruby/ruby-shadow/ChangeLog10
-rw-r--r--dev-ruby/ruby-shadow/files/ruby-shadow-1.4.1-debian.patch51
-rw-r--r--dev-ruby/ruby-shadow/ruby-shadow-1.4.1-r1.ebuild37
3 files changed, 96 insertions, 2 deletions
diff --git a/dev-ruby/ruby-shadow/ChangeLog b/dev-ruby/ruby-shadow/ChangeLog
index 1a47bbc42ee7..4a093997299c 100644
--- a/dev-ruby/ruby-shadow/ChangeLog
+++ b/dev-ruby/ruby-shadow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-shadow
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shadow/ChangeLog,v 1.7 2009/08/09 12:22:17 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shadow/ChangeLog,v 1.8 2010/02/07 13:34:14 graaff Exp $
+
+*ruby-shadow-1.4.1-r1 (07 Feb 2010)
+
+ 07 Feb 2010; Hans de Graaff <graaff@gentoo.org>
+ +ruby-shadow-1.4.1-r1.ebuild, +files/ruby-shadow-1.4.1-debian.patch:
+ Convert to ruby-ng. Add Debian patch to fix #302798.
09 Aug 2009; nixnut <nixnut@gentoo.org> ruby-shadow-1.4.1.ebuild:
ppc stable #274170
diff --git a/dev-ruby/ruby-shadow/files/ruby-shadow-1.4.1-debian.patch b/dev-ruby/ruby-shadow/files/ruby-shadow-1.4.1-debian.patch
new file mode 100644
index 000000000000..2e56fffeaa65
--- /dev/null
+++ b/dev-ruby/ruby-shadow/files/ruby-shadow-1.4.1-debian.patch
@@ -0,0 +1,51 @@
+--- libshadow-ruby-1.4.1.orig/shadow.c
++++ libshadow-ruby-1.4.1/shadow.c
+@@ -60,7 +60,7 @@
+ INT2FIX(entry->sp_inact),
+ INT2FIX(entry->sp_expire),
+ INT2FIX(entry->sp_flag),
+- 0);
++ NULL);
+ free(entry);
+ return result;
+ };
+@@ -89,7 +89,7 @@
+ INT2FIX(entry->sp_inact),
+ INT2FIX(entry->sp_expire),
+ INT2FIX(entry->sp_flag),
+- 0);
++ NULL);
+ return result;
+ };
+
+@@ -114,7 +114,7 @@
+ INT2FIX(entry->sp_inact),
+ INT2FIX(entry->sp_expire),
+ INT2FIX(entry->sp_flag),
+- 0);
++ NULL);
+ return result;
+ };
+
+@@ -142,7 +142,7 @@
+ INT2FIX(entry->sp_inact),
+ INT2FIX(entry->sp_expire),
+ INT2FIX(entry->sp_flag),
+- 0);
++ NULL);
+ return result;
+ };
+
+@@ -254,10 +254,10 @@
+ rb_sPasswdEntry = rb_struct_define("PasswdEntry",
+ "sp_namp","sp_pwdp","sp_lstchg",
+ "sp_min","sp_max","sp_warn",
+- "sp_inact","sp_expire","sp_flag",0);
++ "sp_inact","sp_expire","sp_flag",NULL);
+ rb_sGroupEntry = rb_struct_define("GroupEntry",
+ "sg_name","sg_passwd",
+- "sg_adm","sg_mem",0);
++ "sg_adm","sg_mem",NULL);
+
+ rb_mShadow = rb_define_module("Shadow");
+ rb_eFileLock = rb_define_class_under(rb_mShadow,"FileLock",rb_eException);
diff --git a/dev-ruby/ruby-shadow/ruby-shadow-1.4.1-r1.ebuild b/dev-ruby/ruby-shadow/ruby-shadow-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..257d30bfb74f
--- /dev/null
+++ b/dev-ruby/ruby-shadow/ruby-shadow-1.4.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shadow/ruby-shadow-1.4.1-r1.ebuild,v 1.1 2010/02/07 13:34:14 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="ruby shadow bindings"
+HOMEPAGE="http://ttsky.net"
+SRC_URI="http://ttsky.net/src/${P}.tar.gz"
+
+S=${WORKDIR}/shadow-${PV}
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-debian.patch" )
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "Configuration failed."
+}
+
+each_ruby_compile() {
+ emake || die "Compilation failed."
+}
+
+each_ruby_install() {
+ emake install DESTDIR="${D}" || die "Installation failed."
+}
+
+all_ruby_install() {
+ dodoc HISTORY README README.euc
+}