summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-04-19 18:45:44 +0000
committerHans de Graaff <graaff@gentoo.org>2015-04-19 18:45:44 +0000
commit56dfb0b428958219a4fbd2d4aa46795240d86502 (patch)
tree4894178e1c3160a2eb5d0ae135b20f3c525acb70 /dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild
parentppc/ppc64/x86 stable, bug #541116 (diff)
downloadgentoo-2-56dfb0b428958219a4fbd2d4aa46795240d86502.tar.gz
gentoo-2-56dfb0b428958219a4fbd2d4aa46795240d86502.tar.bz2
gentoo-2-56dfb0b428958219a4fbd2d4aa46795240d86502.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild')
-rw-r--r--dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild
new file mode 100644
index 000000000000..54aada56d96a
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild,v 1.1 2015/04/19 18:45:44 graaff Exp $
+
+EAPI=5
+
+# ruby22 -> Does not compile
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-ng
+
+DESCRIPTION="A TCP wrappers library for Ruby"
+HOMEPAGE="http://raa.ruby-lang.org/list.rhtml?name=ruby-tcpwrap"
+SRC_URI="http://shugo.net/archive/ruby-tcpwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" net-libs/libident
+ sys-apps/tcp-wrappers"
+
+RDEPEND+=" net-libs/libident
+ sys-apps/tcp-wrappers"
+
+RUBY_S="${PN}"
+RUBY_PATCHES=( "${P}-ruby19.patch" )
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but the Ruby-Gnome bindings
+ # unfortunately rely on the lazy load of other extensions; see bug
+ # #320545.
+ find . -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined ::' || die "--no-undefined removal failed"
+
+ emake V=1
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install V=1
+}
+
+all_ruby_install() {
+ dodoc README*
+ dohtml doc/*
+
+ docinto sample
+ dodoc sample/*
+}