summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-28 10:01:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-28 10:01:57 +0000
commit72c9266ad6cf3334f9fb6ab104fb4c211f09bad5 (patch)
treee74c709740e1e30c9a764b6a3c662c807c694cda /dev-ruby/rubypants
parentEAPI3 (diff)
downloadgentoo-2-72c9266ad6cf3334f9fb6ab104fb4c211f09bad5.tar.gz
gentoo-2-72c9266ad6cf3334f9fb6ab104fb4c211f09bad5.tar.bz2
gentoo-2-72c9266ad6cf3334f9fb6ab104fb4c211f09bad5.zip
Revision bump to drop ruby19 and create a stable candidate. Add ree18.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rubypants')
-rw-r--r--dev-ruby/rubypants/ChangeLog8
-rw-r--r--dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild4
-rw-r--r--dev-ruby/rubypants/rubypants-0.2.0-r2.ebuild28
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-ruby/rubypants/ChangeLog b/dev-ruby/rubypants/ChangeLog
index 7bd4d222eba5..11898a1f90a1 100644
--- a/dev-ruby/rubypants/ChangeLog
+++ b/dev-ruby/rubypants/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rubypants
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/ChangeLog,v 1.7 2011/01/07 15:06:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/ChangeLog,v 1.8 2011/01/28 10:01:57 graaff Exp $
+
+*rubypants-0.2.0-r2 (28 Jan 2011)
+
+ 28 Jan 2011; Hans de Graaff <graaff@gentoo.org> rubypants-0.2.0-r1.ebuild,
+ +rubypants-0.2.0-r2.ebuild:
+ Revision bump to drop ruby19 and create a stable candidate. Add ree18.
07 Jan 2011; Hans de Graaff <graaff@gentoo.org> rubypants-0.2.0-r1.ebuild:
Use proper call to install gemspec now that the eclass changed interface.
diff --git a/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild b/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild
index c8fe8459b8dc..1b292b89a316 100644
--- a/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild
+++ b/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild,v 1.3 2011/01/07 15:06:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/rubypants-0.2.0-r1.ebuild,v 1.4 2011/01/28 10:01:57 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST="test"
diff --git a/dev-ruby/rubypants/rubypants-0.2.0-r2.ebuild b/dev-ruby/rubypants/rubypants-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..e4a7e8af9772
--- /dev/null
+++ b/dev-ruby/rubypants/rubypants-0.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/rubypants-0.2.0-r2.ebuild,v 1.1 2011/01/28 10:01:57 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby port of the SmartyPants PHP library."
+HOMEPAGE="http://chneukirchen.org/blog/static/projects/rubypants.html"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_install() {
+ ruby_fakegem_install_gemspec
+
+ ruby_fakegem_newins rubypants.rb lib/rubypants.rb
+}