summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-09 11:49:30 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-09 11:49:30 +0000
commit1b7c7616e50053b343088b7fd8c2b7ad139e052a (patch)
tree34ffbb206b2c1d3c7979c080d8bbf7974c27b796 /dev-ruby/sinatra
parentRemove unused files. (diff)
downloadgentoo-2-1b7c7616e50053b343088b7fd8c2b7ad139e052a.tar.gz
gentoo-2-1b7c7616e50053b343088b7fd8c2b7ad139e052a.tar.bz2
gentoo-2-1b7c7616e50053b343088b7fd8c2b7ad139e052a.zip
Remove unused files.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/sinatra')
-rw-r--r--dev-ruby/sinatra/ChangeLog7
-rw-r--r--dev-ruby/sinatra/files/sinatra-1.0-haml3-tests.patch106
-rw-r--r--dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-require.patch18
-rw-r--r--dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-tests.patch43
4 files changed, 6 insertions, 168 deletions
diff --git a/dev-ruby/sinatra/ChangeLog b/dev-ruby/sinatra/ChangeLog
index df1103d8978a..8239598c6d49 100644
--- a/dev-ruby/sinatra/ChangeLog
+++ b/dev-ruby/sinatra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/sinatra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sinatra/ChangeLog,v 1.50 2014/08/15 14:01:51 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sinatra/ChangeLog,v 1.51 2014/12/09 11:49:30 mrueg Exp $
+
+ 09 Dec 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/sinatra-1.0-haml3-tests.patch, -files/sinatra-1.3.1-rdoc-require.patch,
+ -files/sinatra-1.3.1-rdoc-tests.patch:
+ Remove unused files.
15 Aug 2014; Anthony G. Basile <blueness@gentoo.org> sinatra-1.3.3.ebuild,
sinatra-1.4.3.ebuild, sinatra-1.4.4.ebuild, sinatra-1.4.5.ebuild:
diff --git a/dev-ruby/sinatra/files/sinatra-1.0-haml3-tests.patch b/dev-ruby/sinatra/files/sinatra-1.0-haml3-tests.patch
deleted file mode 100644
index de41fb066f07..000000000000
--- a/dev-ruby/sinatra/files/sinatra-1.0-haml3-tests.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-commit b5bc740c12024df855991ae7437ef2df113d1ab3
-Author: Simon Rozet <simon@rozet.name>
-Date: Wed May 12 07:11:05 2010 +0200
-
- fix test for haml 3
-
-diff --git a/test/sass_test.rb b/test/sass_test.rb
-index 200554c..596e3c4 100644
---- a/test/sass_test.rb
-+++ b/test/sass_test.rb
-@@ -13,21 +13,21 @@ class SassTest < Test::Unit::TestCase
- end
-
- it 'renders inline Sass strings' do
-- sass_app { sass "#sass\n :background-color #FFF\n" }
-+ sass_app { sass "#sass\n :background-color white\n" }
- assert ok?
-- assert_equal "#sass {\n background-color: #FFF; }\n", body
-+ assert_equal "#sass {\n background-color: white; }\n", body
- end
-
- it 'renders .sass files in views path' do
- sass_app { sass :hello }
- assert ok?
-- assert_equal "#sass {\n background-color: #FFF; }\n", body
-+ assert_equal "#sass {\n background-color: white; }\n", body
- end
-
- it 'ignores the layout option' do
- sass_app { sass :hello, :layout => :layout2 }
- assert ok?
-- assert_equal "#sass {\n background-color: #FFF; }\n", body
-+ assert_equal "#sass {\n background-color: white; }\n", body
- end
-
- it "raises error if template not found" do
-@@ -39,44 +39,50 @@ class SassTest < Test::Unit::TestCase
-
- it "passes SASS options to the Sass engine" do
- sass_app {
-- sass "#sass\n :background-color #FFF\n :color #000\n", :style => :compact
-+ sass "#sass\n :background-color white\n :color black\n",
-+ :style => :compact
- }
- assert ok?
-- assert_equal "#sass { background-color: #FFF; color: #000; }\n", body
-+ assert_equal "#sass { background-color: white; color: black; }\n", body
- end
-
- it "passes default SASS options to the Sass engine" do
- mock_app {
- set :sass, {:style => :compact} # default Sass style is :nested
- get '/' do
-- sass "#sass\n :background-color #FFF\n :color #000\n"
-+ sass "#sass\n :background-color white\n :color black\n"
- end
- }
- get '/'
- assert ok?
-- assert_equal "#sass { background-color: #FFF; color: #000; }\n", body
-+ assert_equal "#sass { background-color: white; color: black; }\n", body
- end
-
-- it "merges the default SASS options with the overrides and passes them to the Sass engine" do
-+ it "merges the default SASS options with the overrides" do
- mock_app {
-- set :sass, {:style => :compact, :attribute_syntax => :alternate } # default Sass attribute_syntax is :normal (with : in front)
-+ # default Sass attribute_syntax is :normal (with : in front)
-+ set :sass, {:style => :compact, :attribute_syntax => :alternate }
- get '/' do
-- sass "#sass\n background-color: #FFF\n color: #000\n"
-+ sass "#sass\n background-color: white\n color: black\n"
- end
- get '/raised' do
-- sass "#sass\n :background-color #FFF\n :color #000\n", :style => :expanded # retains global attribute_syntax settings
-+ # retains global attribute_syntax settings
-+ sass "#sass\n :background-color white\n :color black\n",
-+ :style => :expanded
- end
- get '/expanded_normal' do
-- sass "#sass\n :background-color #FFF\n :color #000\n", :style => :expanded, :attribute_syntax => :normal
-+ sass "#sass\n :background-color white\n :color black\n",
-+ :style => :expanded, :attribute_syntax => :normal
- end
- }
- get '/'
- assert ok?
-- assert_equal "#sass { background-color: #FFF; color: #000; }\n", body
-+ assert_equal "#sass { background-color: white; color: black; }\n", body
- assert_raise(Sass::SyntaxError) { get('/raised') }
- get '/expanded_normal'
- assert ok?
-- assert_equal "#sass {\n background-color: #FFF;\n color: #000;\n}\n", body
-+ assert_equal "#sass {\n background-color: white;\n color: black;\n}\n",
-+ body
- end
- end
-
-diff --git a/test/views/hello.sass b/test/views/hello.sass
-index 5a4fd57..090bd4a 100644
---- a/test/views/hello.sass
-+++ b/test/views/hello.sass
-@@ -1,2 +1,2 @@
- #sass
-- :background-color #FFF
-+ :background-color white
diff --git a/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-require.patch b/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-require.patch
deleted file mode 100644
index 0c6fca5ab694..000000000000
--- a/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-require.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-commit dc1ff1867096c5ef036c7aff9b55e4e72e4eaa6a
-Author: Tim Felgentreff <timfelgentreff@gmail.com>
-Date: Mon Oct 10 18:57:14 2011 -0700
-
- Update rdoc test to work with RDoc 3.10
-
-diff --git a/test/rdoc_test.rb b/test/rdoc_test.rb
-index ff547bc..d28b16a 100644
---- a/test/rdoc_test.rb
-+++ b/test/rdoc_test.rb
-@@ -1,6 +1,7 @@
- require File.expand_path('../helper', __FILE__)
-
- begin
-+require 'rdoc'
- require 'rdoc/markup/to_html'
-
- class RdocTest < Test::Unit::TestCase
diff --git a/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-tests.patch b/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-tests.patch
deleted file mode 100644
index 540781f453a7..000000000000
--- a/dev-ruby/sinatra/files/sinatra-1.3.1-rdoc-tests.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit 3d78b5ee6c18d5776ddf9c7d148158a3604f80e6
-Author: Tim Felgentreff <timfelgentreff@gmail.com>
-Date: Mon Oct 10 19:50:59 2011 -0700
-
- fix rdoc tests for 3.10
-
-diff --git a/test/helper.rb b/test/helper.rb
-index 1f061d4..dc8fd40 100644
---- a/test/helper.rb
-+++ b/test/helper.rb
-@@ -69,7 +69,11 @@ class Test::Unit::TestCase
- end
-
- def assert_body(value)
-- assert_equal value.lstrip.gsub(/\s*\n\s*/, ""), body.lstrip.gsub(/\s*\n\s*/, "")
-+ if value.respond_to? :to_str
-+ assert_equal value.lstrip.gsub(/\s*\n\s*/, ""), body.lstrip.gsub(/\s*\n\s*/, "")
-+ else
-+ assert_match value, body
-+ end
- end
-
- def assert_status(expected)
-diff --git a/test/rdoc_test.rb b/test/rdoc_test.rb
-index d28b16a..0d58856 100644
---- a/test/rdoc_test.rb
-+++ b/test/rdoc_test.rb
-@@ -16,13 +16,13 @@ class RdocTest < Test::Unit::TestCase
- it 'renders inline rdoc strings' do
- rdoc_app { rdoc '= Hiya' }
- assert ok?
-- assert_body "<h1>Hiya</h1>"
-+ assert_body /<h1[^>]*>Hiya<\/h1>/
- end
-
- it 'renders .rdoc files in views path' do
- rdoc_app { rdoc :hello }
- assert ok?
-- assert_body "<h1>Hello From RDoc</h1>"
-+ assert_body /<h1[^>]*>Hello From RDoc<\/h1>/
- end
-
- it "raises error if template not found" do