summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-16 05:43:23 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-16 05:43:23 +0000
commit14aa779aa633f681239dc226bf5882dad8c84762 (patch)
tree7a669b77a90258d2f7db1349686493230ad4b45b /dev-ruby/test-spec
parentFixes bug 366713 (diff)
downloadgentoo-2-14aa779aa633f681239dc226bf5882dad8c84762.tar.gz
gentoo-2-14aa779aa633f681239dc226bf5882dad8c84762.tar.bz2
gentoo-2-14aa779aa633f681239dc226bf5882dad8c84762.zip
Revision bump to create a stable candidate.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-spec')
-rw-r--r--dev-ruby/test-spec/ChangeLog10
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild13
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r3.ebuild41
3 files changed, 52 insertions, 12 deletions
diff --git a/dev-ruby/test-spec/ChangeLog b/dev-ruby/test-spec/ChangeLog
index 4d54c1755ce9..0e90b81e1f62 100644
--- a/dev-ruby/test-spec/ChangeLog
+++ b/dev-ruby/test-spec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/test-spec
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.16 2010/05/23 10:46:04 a3li Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.17 2011/05/16 05:43:23 graaff Exp $
+
+*test-spec-0.10.0-r3 (16 May 2011)
+
+ 16 May 2011; Hans de Graaff <graaff@gentoo.org> test-spec-0.10.0-r2.ebuild,
+ +test-spec-0.10.0-r3.ebuild:
+ Revision bump to create a stable candidate.
23 May 2010; Alex Legler <a3li@gentoo.org> test-spec-0.10.0-r2.ebuild:
Add REE18 support
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
index 69694732e522..585ee5e2d1d0 100644
--- a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.10 2010/05/23 10:46:04 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.11 2011/05/16 05:43:23 graaff Exp $
EAPI="2"
-# ruby19 → incompatible with test-unit so fails badly
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_EXTRADOC="README SPECS ROADMAP TODO"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -23,12 +22,6 @@ IUSE=""
ruby_add_rdepend virtual/ruby-test-unit
ruby_add_bdepend test dev-ruby/mocha
-# On Ruby 1.9, the tests only work with test-unit-2, but generally
-# speaking, test-spec should work fine with test-unit-1.2.3, and
-# indeed some testsuites only work with that.
-USE_RUBY=ruby19 \
- ruby_add_bdepend "ruby_targets_ruby19 test" '>=dev-ruby/test-unit-2.0.6'
-
all_ruby_prepare() {
epatch "${FILESDIR}"/${P}-jruby.patch
}
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r3.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r3.ebuild
new file mode 100644
index 000000000000..19d38d67369d
--- /dev/null
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r3.ebuild,v 1.1 2011/05/16 05:43:23 graaff Exp $
+
+EAPI="2"
+
+# ruby19 → incompatible with test-unit so fails badly
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README SPECS ROADMAP TODO"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A library to do Behavior Driven Development with Test::Unit"
+HOMEPAGE="http://chneukirchen.org/blog/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend virtual/ruby-test-unit
+ruby_add_bdepend test dev-ruby/mocha
+
+# On Ruby 1.9, the tests only work with test-unit-2, but generally
+# speaking, test-spec should work fine with test-unit-1.2.3, and
+# indeed some testsuites only work with that.
+USE_RUBY=ruby19 \
+ ruby_add_bdepend "ruby_targets_ruby19 test" '>=dev-ruby/test-unit-2.0.6'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-jruby.patch
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}