summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-12-16 15:23:15 +0000
committerAlex Legler <a3li@gentoo.org>2009-12-16 15:23:15 +0000
commitb176f678fe91dd25e5305e196d0c072f53e9d226 (patch)
treea10d072eba5e6569afd1b0b85d9bc356c20dcf29 /dev-ruby/test-spec
parentUpdate HAL 0.5.14 patch wrt #296544 by Nate Weibley. (diff)
downloadgentoo-2-b176f678fe91dd25e5305e196d0c072f53e9d226.tar.gz
gentoo-2-b176f678fe91dd25e5305e196d0c072f53e9d226.tar.bz2
gentoo-2-b176f678fe91dd25e5305e196d0c072f53e9d226.zip
Revbump, move to ruby-fakegem
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-spec')
-rw-r--r--dev-ruby/test-spec/ChangeLog7
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ruby/test-spec/ChangeLog b/dev-ruby/test-spec/ChangeLog
index 643a646f5fc6..f149889c7bb7 100644
--- a/dev-ruby/test-spec/ChangeLog
+++ b/dev-ruby/test-spec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-spec
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.5 2009/08/07 17:35:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.6 2009/12/16 15:23:15 a3li Exp $
+
+*test-spec-0.10.0-r1 (16 Dec 2009)
+
+ 16 Dec 2009; Alex Legler <a3li@gentoo.org> +test-spec-0.10.0-r1.ebuild:
+ Revbump, move to ruby-fakegem
07 Aug 2009; Hans de Graaff <graaff@gentoo.org> -test-spec-0.4.0.ebuild,
-test-spec-0.9.0.ebuild:
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..7bebd8be0862
--- /dev/null
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild,v 1.1 2009/12/16 15:23:15 a3li Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19"
+inherit ruby-fakegem
+
+DESCRIPTION="A library to do Behavior Driven Development with Test::Unit"
+HOMEPAGE="http://chneukirchen.org/blog/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper specrb
+ dodoc README SPECS || die
+
+ if use doc; then
+ dodoc examples/* || die
+ fi
+}