summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-02 06:22:14 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-02 06:22:14 +0000
commit934ffc0f18c3a3515f3d266cca36257f37835b9b (patch)
treee06c1100b74b1dd1c1fa24434bfc58382faa6716 /dev-ruby/treetop
parentVersion bump, bug #312337, thank Richard Hartmann for report. Fixes inability... (diff)
downloadgentoo-2-934ffc0f18c3a3515f3d266cca36257f37835b9b.tar.gz
gentoo-2-934ffc0f18c3a3515f3d266cca36257f37835b9b.tar.bz2
gentoo-2-934ffc0f18c3a3515f3d266cca36257f37835b9b.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/treetop')
-rw-r--r--dev-ruby/treetop/ChangeLog7
-rw-r--r--dev-ruby/treetop/treetop-1.4.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index 00f70e80588b..ce656af374ad 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.12 2010/02/20 07:37:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.13 2010/04/02 06:22:14 graaff Exp $
+
+*treetop-1.4.5 (02 Apr 2010)
+
+ 02 Apr 2010; Hans de Graaff <graaff@gentoo.org> +treetop-1.4.5.ebuild:
+ Version bump.
*treetop-1.4.4 (20 Feb 2010)
diff --git a/dev-ruby/treetop/treetop-1.4.5.ebuild b/dev-ruby/treetop/treetop-1.4.5.ebuild
new file mode 100644
index 000000000000..ca018f2249a7
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.5.ebuild,v 1.1 2010/04/02 06:22:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Failed installing example files."
+}