summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-22 07:07:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-22 07:07:59 +0000
commit0362c475aba20ff763e53c4b6f983f407ec8da72 (patch)
tree111157dfb9afe2ef37c6c59a53759b0bd24af0fa /dev-ruby/vlad
parentBump to autoconf-archive-2011.12.21. (diff)
downloadgentoo-2-0362c475aba20ff763e53c4b6f983f407ec8da72.tar.gz
gentoo-2-0362c475aba20ff763e53c4b6f983f407ec8da72.tar.bz2
gentoo-2-0362c475aba20ff763e53c4b6f983f407ec8da72.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/vlad')
-rw-r--r--dev-ruby/vlad/ChangeLog7
-rw-r--r--dev-ruby/vlad/vlad-2.2.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/vlad/ChangeLog b/dev-ruby/vlad/ChangeLog
index 472fe0d2f253..caeebe80dced 100644
--- a/dev-ruby/vlad/ChangeLog
+++ b/dev-ruby/vlad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/vlad
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.15 2011/10/19 17:58:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.16 2011/12/22 07:07:59 graaff Exp $
+
+*vlad-2.2.4 (22 Dec 2011)
+
+ 22 Dec 2011; Hans de Graaff <graaff@gentoo.org> +vlad-2.2.4.ebuild:
+ Version bump.
*vlad-2.2.3 (19 Oct 2011)
diff --git a/dev-ruby/vlad/vlad-2.2.4.ebuild b/dev-ruby/vlad/vlad-2.2.4.ebuild
new file mode 100644
index 000000000000..d545d0cfc482
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.2.4.ebuild,v 1.1 2011/12/22 07:07:59 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy."
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.0.0"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}